zoukankan      html  css  js  c++  java
  • 【贪心】Mixing Milk

    题目描述

    The Merry Milk Makers company buys milk from farmers, packages it into attractive 1- and 2-Unit bottles, and then sells that milk to grocery stores so we can each start our day with delicious cereal and milk.
    Since milk packaging is such a difficult business in which to make money, it is important to keep the costs as low as possible. Help Merry Milk Makers purchase the farmers' milk in the cheapest possible manner. The MMM company has an extraordinarily talented marketing department and knows precisely how much milk they need each day to package for their customers.
    The company has contracts with several farmers from whom they may purchase milk, and each farmer has a (potentially) different price at which they sell milk to the packing plant. Of course, a herd of cows can only produce so much milk each day, so the farmers already know how much milk they will have available.
    Each day, Merry Milk Makers can purchase an integer number of units of milk from each farmer, a number that is always less than or equal to the farmer's limit (and might be the entire production from that farmer, none of the production, or any integer in between).
    Given:
    The Merry Milk Makers' daily requirement of milk
    The cost per unit for milk from each farmer
    The amount of milk available from each farmer
    calculate the minimum amount of money that Merry Milk Makers must spend to meet their daily need for milk.
    Note: The total milk produced per day by the farmers will always be sufficient to meet the demands of the Merry Milk Makers even if the prices are high.

    输入

    Line 1: Two integers, N and M. The first value, N, (0 <= N <= 2,000,000) is the amount of milk that Merry Milk Makers wants per day. The second, M, (0 <= M <= 5,000) is the number of farmers that they may buy from. 
    Lines 2 through M+1: The next M lines each contain two integers: Pi and Ai. Pi (0 <= Pi <= 1,000) is price in cents that farmer i charges.Ai (0 <= Ai <= 2,000,000) is the amount of milk that farmer i can sell to Merry Milk Makers per day.

    输出

    A single line with a single integer that is the minimum cost that Merry Milk Makers must pay for one day's milk.

    样例输入

    100 5
    5 20
    9 40
    3 10
    8 80
    6 30

    样例输出

    630

    分析:先排序,从便宜的买,直到买够。

    #include <iostream>
    #include <string>
    #include <cstdio>
    #include <cmath>
    #include <cstring>
    #include <algorithm>
    #include <vector>
    #include <queue>
    #define range(i,a,b) for(int i=a;i<=b;++i)
    #define LL long long
    #define rerange(i,a,b) for(int i=a;i>=b;--i)
    #define fill(arr,tmp) memset(arr,tmp,sizeof(arr))
    using namespace std;
    int n,m;
    struct node{
        int p,a;
    }data[5005];
    bool cmp(node a,node b){
        return a.p<b.p;
    }
    void init(){
        cin>>n>>m;
        range(i,1,m)cin>>data[i].p>>data[i].a;
        sort(data+1,data+1+m,cmp);
    }
    void solve(){
        LL sum=0,cnt=0;
        range(i,1,m){
            if(n-cnt>=data[i].a){
                cnt+=data[i].a;
                sum+=data[i].a*data[i].p;
            }
            else{
                sum+=data[i].p*(n-cnt);
                break;
            }
        }
        cout<<sum<<endl;
    }
    int main() {
        init();
        solve();
        return 0;
    }
    View Code
  • 相关阅读:
    动手动脑
    原码反码补码
    考试感想
    第八周
    第七周
    第六周
    第五周
    第四周
    Hamburger Magi(hdu 3182)
    Doing Homework(hdu)1074
  • 原文地址:https://www.cnblogs.com/Rhythm-/p/9326843.html
Copyright © 2011-2022 走看看