zoukankan      html  css  js  c++  java
  • 【字符串】Your Ride Is Here

    题目描述

    It is a well-known fact that behind every good comet is a UFO. These UFOs often come to collect loyal supporters from here on Earth. Unfortunately, they only have room to pick up one group of followers on each trip. They do, however, let the groups know ahead of time which will be picked up for each comet by a clever scheme: they pick a name for the comet which, along with the name of the group, can be used to determine if it is a particular group's turn to go (who do you think names the comets?). The details of the matching scheme are given below; your job is to write a program which takes the names of a group and a comet and then determines whether the group should go with the UFO behind that comet.

    Both the name of the group and the name of the comet are converted into a number in the following manner: the final number is just the product of all the letters in the name, where "A" is 1 and "Z" is 26. For instance, the group "USACO" would be 21 * 19 * 1 * 3 * 15 = 17955. If the group's number mod 47 is the same as the comet's number mod 47, then you need to tell the group to get ready! (Remember that "a mod b" is the remainder left over after dividing a by b; 34 mod 10 is 4.)

    Write a program which reads in the name of the comet and the name of the group and figures out whether according to the above scheme the names are a match, printing "GO" if they match and "STAY" if not. The names of the groups and the comets will be a string of capital letters with no spaces or punctuation, up to 6 characters long.

    输入

    Line 1: An upper case character string of length 1..6 that is the name of the comet.
    Line 2: An upper case character string of length 1..6 that is the name of the group.

    输出

    A single line containing either the word "GO" or the word "STAY".

    样例输入

    COMETQ
    HVNGAT

    样例输出

    GO

    分析:按题意走呗,他说怎样就怎样~。

    #include <iostream>
    #include <string>
    #include <cstdio>
    #include <cmath>
    #include <cstring>
    #include <algorithm>
    #include <vector>
    #include <queue>
    #define range(i,a,b) for(int i=a;i<=b;++i)
    #define LL long long
    #define rerange(i,a,b) for(int i=a;i>=b;--i)
    #define fill(arr,tmp) memset(arr,tmp,sizeof(arr))
    using namespace std;
    string a,b;
    LL mul1,mul2;
    void init(){
        cin>>a>>b;
        mul1=mul2=1;
    }
    void solve(){
        range(i,0,a.size()-1)mul1*=a[i]-'A'+1;
        range(i,0,b.size()-1)mul2*=b[i]-'A'+1;
        cout<<(mul1%47==mul2%47?"GO":"STAY")<<endl;
    }
    int main() {
        init();
        solve();
        return 0;
    }
    View Code
  • 相关阅读:
    JUC学习
    java反射学习
    JSON入门学习
    redis
    NoSQ学习
    手写Lockl锁
    MapReduce过程
    scala学习
    idea jetty 配置
    java 基础--理论知识
  • 原文地址:https://www.cnblogs.com/Rhythm-/p/9326854.html
Copyright © 2011-2022 走看看