zoukankan      html  css  js  c++  java
  • 【模拟】Friday the Thirteenth

    题目描述

    Is Friday the 13th really an unusual event?
    That is, does the 13th of the month land on a Friday less often than on any other day of the week? To answer this question, write a program that will compute the frequency that the 13th of each month lands on Sunday, Monday, Tuesday, Wednesday, Thursday, Friday, and Saturday over a given period of N years. The time period to test will be from January 1, 1900 to December 31, 1900+N-1 for a given number of years, N. N is positive and will not exceed 400.
    Note that the start year is NINETEEN HUNDRED, not 1990.
    There are few facts you need to know before you can solve this problem:
    January 1, 1900 was on a Monday.
    Thirty days has September, April, June, and November, all the rest have 31 except for February which has 28 except in leap years when it has 29.
    Every year evenly divisible by 4 is a leap year (1992 = 4*498 so 1992 will be a leap year, but the year 1990 is not a leap year)
    The rule above does not hold for century years. Century years divisible by 400 are leap years, all other are not. Thus, the century years 1700, 1800, 1900 and 2100 are not leap years, but 2000 is a leap year.
    Do not use any built-in date functions in your computer language.
    Don't just precompute the answers, either, please.

    输入

    One line with the integer N.

    输出

    Seven space separated integers on one line. These integers represent the number of times the 13th falls on Saturday, Sunday, Monday, Tuesday, ..., Friday.

    样例输入

    20

    样例输出

    36 33 34 33 35 35 34

    #include <iostream>
    #include <string>
    #include <cstdio>
    #include <cmath>
    #include <cstring>
    #include <algorithm>
    #include <vector>
    #include <queue>
    #define range(i,a,b) for(int i=a;i<=b;++i)
    #define LL long long
    #define rerange(i,a,b) for(int i=a;i>=b;--i)
    #define fill(arr,tmp) memset(arr,tmp,sizeof(arr))
    using namespace std;
    string a,b;
    LL mul1,mul2;
    void init(){
        cin>>a>>b;
        mul1=mul2=1;
    }
    void solve(){
        range(i,0,a.size()-1)mul1*=a[i]-'A'+1;
        range(i,0,b.size()-1)mul2*=b[i]-'A'+1;
        cout<<(mul1%47==mul2%47?"GO":"STAY")<<endl;
    }
    int main() {
        init();
        solve();
        return 0;
    }
    View Code
  • 相关阅读:
    为甚么 国企做互联网总做不起来?
    WEB开发:Java与Php对比
    String中的CompareTo
    String API
    死锁(Deadlock)
    100人100盏灯(详解)
    debian、ubuntu安装metasploit通用方法
    xman随机数相关题目
    CTF辅助脚本
    2019全国大学生信息安全竞赛ciscn-writeup(4web)
  • 原文地址:https://www.cnblogs.com/Rhythm-/p/9326868.html
Copyright © 2011-2022 走看看