zoukankan      html  css  js  c++  java
  • Codeup 问题 D: String Subtraction (20)

    题目描述

    Given two strings S1 and S2, S = S1 - S2 is defined to be the remaining string after taking all the characters in S2 from S1. Your task is simply to calculate S1 - S2for any given strings. However, it might not be that simple to do it fast.

    输入

    Each input file contains one test case. Each case consists of two lines which gives S1 and S2, respectively. The string lengths of both strings are no more than 104. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

    输出

    For each test case, print S1 - S2 in one line.

    样例输入

    They are students.
    aeiou

    样例输出

    Thy r stdnts.

    [提交][状态]

    #include<iostream>
    #include<cstring>
    #include<algorithm>
    using namespace std;
    
    char a[10000+10],b[10000+10];
    
    int main()
    {
    	bool vis[600]={false};
    	int n,m,h,j,i,T;
    	gets(a);
    	gets(b);
    	{
    		int lenb=strlen(b);
    		for (i=0;i<lenb;i++)
    		{
    			vis[b[i]-'A'] = true;
    		}
    		for (i=0;i<strlen(a);i++)
    		{
    			if (vis[a[i]-'A']==false)
    			cout<<a[i];
    		}
    		cout<<endl;
    	}
    	return 0;
    }
  • 相关阅读:
    [bzoj3123] [Sdoi2013]森林
    [bzoj2173] 整数的lqp拆分
    Linux
    使用高德地图API
    EF具体用在什么类型的项目上
    出现Data Tools 与VS 不兼容问题
    Entity FramWork
    Entity
    Entity
    BASH
  • 原文地址:https://www.cnblogs.com/Romantic-Chopin/p/12451392.html
Copyright © 2011-2022 走看看