zoukankan      html  css  js  c++  java
  • ACM-ICPC 2018 徐州赛区网络预赛 Characters with Hash

    Mur loves hash algorithm, and he sometimes encrypt another one's name, and call him with that encrypted value. For instance, he calls Kimura KMR, and calls Suzuki YJSNPI. One day he read a book about SHA-256256 , which can transit a string into just 256256 bits. Mur thought that is really cool, and he came up with a new algorithm to do the similar work. The algorithm works this way: first we choose a single letter L as the seed, and for the input(you can regard the input as a string ss, s[i]s[i] represents the iith character in the string) we calculates the value(|(int) L - s[i]|∣(int)L−s[i]∣), and write down the number(keeping leading zero. The length of each answer equals to 22because the string only contains letters and numbers). Numbers writes from left to right, finally transfer all digits into a single integer(without leading zero(ss)). For instance, if we choose 'z' as the seed, the string "oMl" becomes "1111 4545 1414".

    It's easy to find out that the algorithm cannot transfer any input string into the same length. Though in despair, Mur still wants to know the length of the answer the algorithm produces. Due to the silliness of Mur, he can even not figure out this, so you are assigned with the work to calculate the answer.

    Input

    First line a integer TT , the number of test cases (T le 10)(T≤10).

    For each test case:

    First line contains a integer NN and a character zz, (N le 1000000)(N≤1000000).

    Second line contains a string with length NN . Problem makes sure that all characters referred in the problem are only letters.

    Output

    A single number which gives the answer.

    样例输入复制

    2
    3 z
    oMl
    6 Y
    YJSNPI

    样例输出复制

    6
    10

    题目来源

    ACM-ICPC 2018 徐州赛区网络预赛

    坑爹的题目 ,坑爹的题目 ,坑爹的题目 ,坑爹的题目 ,坑爹的题目 ,坑爹的题目 ,坑爹的题目 ,坑爹的题目 。

    题目意思大家应该也懂:

    首先,它是由很多个两位数组成的,但是要去掉前导零。

    话不多说,给几个例子大家就都明白了:

    @10 00 08 :答案为 6

    @01 00 08 :答案为 5

    @11 11 11 :答案为 6

    @01 11 11  :答案为 5

    @00 00 00 :答案为 1 ,不为零

    #include<iostream>
    #include<cstring>
    #include<cmath>
    using namespace std;
    
    char a[1000000+10];
    int b[1000000+10];
    
    int main()
    {
    	int n,m,j,k,i,T,ans,start;
    	char ch;
    	cin>>T;
    	while (T--)
    	{
    		ans=0;
    		scanf("%d %c",&n,&ch);
    		scanf("%s",a);
    		for (i=0;i<n;i++)
    		{
    			if (abs((int)ch-a[i])!=0)
    			{
    				start = i;
    				break;
    			}
    		}
    		if (i>=n)
    		{
    			cout<<"1"<<endl;
    			continue;
    		}
    		////////////////////////////////////
    		if (abs((int)ch-a[i])<=9 && abs((int)ch-a[i])>=1 )
    		ans += 1;
    		else
    		ans += 2;
    		
    		for (i=start+1;i<n;i++)
    		{
    			ans+=2;
    		}
    		
    		cout<<ans<<endl;
    	}
    	return 0;	
    } 
  • 相关阅读:
    bzoj 1012: [JSOI2008]最大数maxnumber 线段树
    Codeforces Round #260 (Div. 2) A , B , C 标记,找规律 , dp
    Codeforces Round #256 (Div. 2) E. Divisors 因子+dfs
    Codeforces Round #340 (Div. 2) E. XOR and Favorite Number 莫队算法
    Codeforces Round #348 (VK Cup 2016 Round 2, Div. 1 Edition) C. Little Artem and Random Variable 数学
    BZOJ 1005 [HNOI2008]明明的烦恼 purfer序列,排列组合
    BZOJ 1211: [HNOI2004]树的计数 purfer序列
    UVA 1629 Cake slicing 记忆化搜索
    UVA1630 Folding 区间DP
    BNU 51640 Training Plan DP
  • 原文地址:https://www.cnblogs.com/Romantic-Chopin/p/12451433.html
Copyright © 2011-2022 走看看