zoukankan      html  css  js  c++  java
  • UVA 562 Dividing coins【01背包 / 有一堆各种面值的硬币,将所有硬币分成两堆,使得两堆的总值之差尽可能小】

    It’s commonly known that the Dutch have invented copper-wire. Two Dutch men were fighting over
    a nickel, which was made of copper. They were both so eager to get it and the fighting was so fierce,
    they stretched the coin to great length and thus created copper-wire.
    Not commonly known is that the fighting started, after the two Dutch tried to divide a bag with
    coins between the two of them. The contents of the bag appeared not to be equally divisible. The Dutch
    of the past couldn’t stand the fact that a division should favour one of them and they always wanted
    a fair share to the very last cent. Nowadays fighting over a single cent will not be seen anymore, but
    being capable of making an equal division as fair as possible is something that will remain important
    forever...
    That’s what this whole problem is about. Not everyone is capable of seeing instantly what’s the
    most fair division of a bag of coins between two persons. Your help is asked to solve this problem.
    Given a bag with a maximum of 100 coins, determine the most fair division between two persons.
    This means that the difference between the amount each person obtains should be minimised. The
    value of a coin varies from 1 cent to 500 cents. It’s not allowed to split a single coin.
    Input
    A line with the number of problems n, followed by n times:
    • a line with a non negative integer m (m ≤ 100) indicating the number of coins in the bag
    • a line with m numbers separated by one space, each number indicates the value of a coin.
    Output
    The output consists of n lines. Each line contains the minimal positive difference between the amount
    the two persons obtain when they divide the coins from the corresponding bag.
    Sample Input
    2
    3
    2 3 5
    4
    1 2 4 6
    Sample Output
    0
    1

    【分析】:它所给出的n个钱币加起来sum,将sum/2当作体积,求出在sum/2下的背包最大值,sum-2*dp[sum/2]

    【代码】:

    #include<cstdio>
    #include<string>
    #include<cstdlib>
    #include<cmath>
    #include<iostream>
    #include<cstring>
    #include<set>
    #include<queue>
    #include<algorithm>
    #include<vector>
    #include<map>
    #include<cctype>
    #include<stack>
    #include<sstream>
    #include<list>
    #include<assert.h>
    #include<bitset>
    #include<numeric>
    #define debug() puts("++++")
    #define gcd(a,b) __gcd(a,b)
    #define lson l,m,rt<<1
    #define rson m+1,r,rt<<1|1
    #define fi first
    #define se second
    #define pb push_back
    #define sqr(x) ((x)*(x))
    #define ms(a,b) memset(a,b,sizeof(a))
    #define sz size()
    #define be begin()
    #define pu push_up
    #define pd push_down
    #define cl clear()
    #define lowbit(x) -x&x
    #define all 1,n,1
    #define rep(i,n,x) for(int i=(x); i<(n); i++)
    #define in freopen("in.in","r",stdin)
    #define out freopen("out.out","w",stdout)
    using namespace std;
    typedef long long LL;
    typedef unsigned long long ULL;
    typedef pair<int,int> P;
    const int INF = 0x3f3f3f3f;
    const LL LNF = 1e18;
    const int maxn =  120;
    const int maxm = 1e5 + 10;
    const double PI = acos(-1.0);
    const double eps = 1e-8;
    const int dx[] = {-1,1,0,0,1,1,-1,-1};
    const int dy[] = {0,0,1,-1,1,-1,1,-1};
    const int mon[] = {0, 31, 28, 31, 30, 31, 30, 31, 31, 30, 31, 30, 31};
    const int monn[] = {0, 31, 29, 31, 30, 31, 30, 31, 31, 30, 31, 30, 31};
    /*
    2
    3
    2 3 5
    4
    1 2 4 6
    
    */
    int dp[maxm],a[maxm];
    int n,m;
    int main()
    {
        int t; cin>>t;
        while(t--)
        {
            cin>>n;
            int sum=0;
            memset(dp,0,sizeof(dp));
            for(int i=1;i<=n;i++) cin>>a[i],sum+=a[i];
            for(int i=1;i<=n;i++)
            {
                for(int j=sum/2;j>=a[i];j--)
                {
                    dp[j] = max(dp[j],dp[j-a[i]]+a[i]);
                }
            }
            cout<< sum - 2*dp[sum/2] <<endl;
        }
    }
    
    
  • 相关阅读:
    20169205 2016-2017-2 《移动平台应用开发实践》第4周学习总结
    20169205 2016-2017-2《网络攻防》第4周总结
    20169205 2016-2017-2 《移动平台应用开发实践》第3周学习总结
    tcpdump使用
    wireshark使用
    20169205 2016-2017-2《网络攻防》第3周总结
    OpenSSH/PuTTY/SSH使用
    Aircrack使用
    Metasploit使用
    20155325 2017-2018 1 《信息安全系统设计基础》 第十周学习总结
  • 原文地址:https://www.cnblogs.com/Roni-i/p/9046710.html
Copyright © 2011-2022 走看看