zoukankan      html  css  js  c++  java
  • HDU 3342 Legal or Not(拓扑排序判环)

    Problem Description
    ACM-DIY is a large QQ group where many excellent acmers get together. It is so harmonious that just like a big family. Every day,many "holy cows" like HH, hh, AC, ZT, lcc, BF, Qinz and so on chat on-line to exchange their ideas. When someone has questions, many warm-hearted cows like Lost will come to help. Then the one being helped will call Lost "master", and Lost will have a nice "prentice". By and by, there are many pairs of "master and prentice". But then problem occurs: there are too many masters and too many prentices, how can we know whether it is legal or not?

    We all know a master can have many prentices and a prentice may have a lot of masters too, it's legal. Nevertheless,some cows are not so honest, they hold illegal relationship. Take HH and 3xian for instant, HH is 3xian's master and, at the same time, 3xian is HH's master,which is quite illegal! To avoid this,please help us to judge whether their relationship is legal or not.

    Please note that the "master and prentice" relation is transitive. It means that if A is B's master ans B is C's master, then A is C's master.
     
    Input
    The input consists of several test cases. For each case, the first line contains two integers, N (members to be tested) and M (relationships to be tested)(2 <= N, M <= 100). Then M lines follow, each contains a pair of (x, y) which means x is y's master and y is x's prentice. The input is terminated by N = 0.
    TO MAKE IT SIMPLE, we give every one a number (0, 1, 2,..., N-1). We use their numbers instead of their names.
     
    Output
    For each test case, print in one line the judgement of the messy relationship.
    If it is legal, output "YES", otherwise "NO".
     
    Sample Input
    3 2 0 1 1 2 2 2 0 1 1 0 0 0
     
    Sample Output
    YES NO
     
    Author
    QiuQiu@NJFU
     
    Source
     
    #include<bits/stdc++.h>
    using namespace std;
    int n,m,a,b;
    vector<int> v[105];
    int in[105],vis[105];
    int main()
    {
        while(~scanf("%d%d",&n,&m),n)
        {
            for(int i=0; i<103; i++)v[i].clear();
            memset(in,0,sizeof(in));
            memset(vis,0,sizeof(vis));
            for(int i=0; i<m; i++)
            {
                scanf("%d%d",&a,&b);//a是师傅,b是徒弟,这里采用的是师傅指向徒弟
                v[a].push_back(b);
                in[b]++;//指向谁,谁的入度就++
            }
            int count=n;
            queue<int> q;
            for(int i=0; i<n; i++)//寻找根节点,如果有一个从结尾连到开头的环,也可以在这里判环,因为此时所有的点入度都不为0
            {
                if(in[i]==0)
                {
                    q.push(i);
                    vis[i]=1;
                }
            }
            while(!q.empty())
            {
                int k=q.front();
                count--;
                q.pop();
                for(int i=0; i<v[k].size(); i++)//v[k].size()表示k指向的徒弟的数量
                {
                    int x=v[k][i];
    //                cout<<"i="<<i<<endl;
    //                cout<<"v["<<k<<"]["<<i<<"]="<<x<<endl;
                    in[x]--;
                    if(in[x]==0&&!vis[x])//判环,如果存在环,即in[x]--后不为0,则无法加入队列,使得count无法正常--
                    {
                        q.push(x);
                        vis[x]=1;
                    }
                }
            }
            if(count==0)printf("YES ");
            else printf("NO ");
        }
        return 0;
    }
  • 相关阅读:
    HTML_<select>
    HTML_<a>
    MySQL_知识点
    MySQL_常用SQL语句
    GIT
    MyBatis_传入参数的问题
    js函数防抖与节流总结
    node 常用方法 生成密钥 token验证 验证码生成 (持续更新)
    node 登陆拦截中间件(egg)
    js 给页面容器增加水印
  • 原文地址:https://www.cnblogs.com/RootVount/p/10806226.html
Copyright © 2011-2022 走看看