zoukankan      html  css  js  c++  java
  • SDNU 1354.Cut the Cable(gcd)

    Description

        The company have n(n<=100) long cables(the length is not necessarily the same),we assume that the length of every long cable is an integer and not exceeded 10000 meters. Now we cut them into short cables with the same length. We are required not to waste every long cable and the length of the short cable is the longer the better. Please calculate the longest length of short cable and how many short cables after cutting.

    Input

        The input contains two lines.
        The first line is n, represents the number of long cables.
        The second line has n positive integers separated by spaces, represent the length of long cable.

    Output

        The first line represent the longest length of short cable.
        The second line represent the number of short cables.

    Sample Input

    4
    18 12 24 30

    Sample Output

    6
    14
    思路:这道题说是要切电缆,长度不能有浪费,输入的所有长度是整数,输出的结果长度也是个整数,那就是用gcd来求所有原始长度的最大公约数(让所有原始长度都可以整除,这样就不存在浪费),然后再求数量即可。(我个沙雕居然一开始想用二分,结果发现没法分)
    #include <cstdio>
    #include <iostream>
    #include <cmath>
    #include <string>
    #include <cstring>
    #include <algorithm>
    #include <queue>
    #include <vector>
    #include <map>
    using namespace std;
    #define ll long long
    
    const int inf = 0x3f3f3f3f;
    const int mod = 1e9+7;
    
    int n, a[10000+8], num, len;
    
    int gcd(int x, int y)
    {
        if(y != 0)return gcd(y, x%y);
        return x;
    }
    
    int main()
    {
        num = 0;
        scanf("%d", &n);
        for(int i = 0; i<n; i++)
            scanf("%d", &a[i]);
        len = a[0];
        for(int i = 1; i<n; i++)
            len = gcd(len, a[i]);
        for(int i = 0; i<n; i++)
            num += a[i]/len;
        printf("%d
    %d
    ", len, num);
        return 0;
    }
  • 相关阅读:
    Lucky Coins Sequence
    A == B ?
    Chinese Rings
    51nod 1051 最大子矩阵和
    51nod 1103 N的倍数
    Codeforces Round #429 (Div. 2)
    51nod 1043 幸运号码(数位dp
    51nod 1266 蚂蚁
    51nod 1090 3个数和为0
    51nod 1082 与7无关的数
  • 原文地址:https://www.cnblogs.com/RootVount/p/11262751.html
Copyright © 2011-2022 走看看