zoukankan      html  css  js  c++  java
  • USACO第三道题

    View Code
    Friday the Thirteenth
    
    Is Friday the 13th really an unusual event? 
    
    That is, does the 13th of the month land on a Friday less often than on any other day of the week? To answer this question, write a program that will compute the frequency that the 13th of each month lands on Sunday, Monday, Tuesday, Wednesday, Thursday, Friday, and Saturday over a given period of N years. The time period to test will be from January 1, 1900 to December 31, 1900+N-1 for a given number of years, N. N is positive and will not exceed 400. 
    
    There are few facts you need to know before you can solve this problem: 
    
    January 1, 1900 was on a Monday. 
    Thirty days has September, April, June, and November, all the rest have 31 except for February which has 28 except in leap years when it has 29. 
    Every year evenly divisible by 4 is a leap year (1992 = 4*498 so 1992 will be a leap year, but the year 1990 is not a leap year) 
    The rule above does not hold for century years. Century years divisible by 400 are leap years, all other are not. Thus, the century years 1700, 1800, 1900 and 2100 are not leap years, but 2000 is a leap year. 
    Do not use any built-in date functions in your computer language. 
    
    Don't just precompute the answers, either, please. 
    
    PROGRAM NAME: friday
    INPUT FORMAT
    One line with the integer N. 
    SAMPLE INPUT (file friday.in) 
    20
    
    OUTPUT FORMAT
    Seven space separated integers on one line. These integers represent the number of times the 13th falls on Saturday, Sunday, Monday, Tuesday, ..., Friday. 
    SAMPLE OUTPUT (file friday.out)
    36 33 34 33 35 35 34
    
    /*
    ID: 97980681
    LANG: C
    TASK: friday
    */
    #include<stdio.h>
    int Is_Leap_Year(int year)
    {
           if(year % 4 == 0)
           {
                  if(year % 100 == 0)
                  {
                         if(year % 400 == 0)
                                return 1;
                         else
                               return 0;
                  }
                  else
                         return 1;
           }
           else
                  return 0;
    }
    const int a[12]={31,28,31,30,31,30,31,31,30,31,30,31};
    int week[7] = {0};
    int main()
    {
        freopen("friday.in","r",stdin);
        freopen("friday.out","w",stdout);
        int day = 13, i, n, j;
        scanf("%d",&n);
        for(i = 0;i < n; i++)
        {
            for(j = 0;j < 12;j++)
            {
                week[day%7]++;
                day += a[j];
                if(Is_Leap_Year(1900+i) && j==1)
                day++;
            }
        }
        printf("%d",week[6]);
        for(i = 0;i < 6; i++)
        printf(" %d",week[i]);
        printf("\n");
        return 0;
    }
  • 相关阅读:
    array常用方法总结
    .babelrc参数小解
    async/await方法解析
    html5-entities.js消失问题
    h => h(App)解析
    package.json字段简要解析
    body-parser小解
    mongodb中的__v字段
    module.exports与exports
    freemarker判断对象是否为空
  • 原文地址:https://www.cnblogs.com/SDUTYST/p/2620228.html
Copyright © 2011-2022 走看看