zoukankan      html  css  js  c++  java
  • POJ 1860 Currency Exchange / ZOJ 1544 Currency Exchange (最短路径相关,spfa求环)

    POJ 1860 Currency Exchange / ZOJ 1544 Currency Exchange (最短路径相关,spfa求环)

    Description

    Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency.
    For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR.
    You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges, and real R AB, C AB, R BA and C BA - exchange rates and commissions when exchanging A to B and B to A respectively.
    Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations.

    Input

    The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain 6 numbers each - the description of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=10 3.
    For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10 -2<=rate<=10 2, 0<=commission<=10 2.
    Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 10 4.

    Output

    If Nick can increase his wealth, output YES, in other case output NO to the output file.

    Sample Input

    3 2 1 20.0
    1 2 1.00 1.00 1.00 1.00
    2 3 1.10 1.00 1.10 1.00

    Sample Output

    YES

    Http

    POJ:https://vjudge.net/problem/POJ-1860
    ZOJ:https://vjudge.net/problem/ZOJ-1544

    Source

    最短路径相关,求环

    题目大意

    求一个图中是否有正环

    解决思路

    运用spfa解决,我们用一个Tot记录每一个点进入队列的次数,如果发现某个点的Tot>n,则说明有环

    代码

    #include<iostream>
    #include<cstdio>
    #include<cstdlib>
    #include<algorithm>
    #include<cstring>
    #include<vector>
    #include<queue>
    using namespace std;
    
    const int maxN=201;
    const int inf=2147483647;
    
    class Data
    {
    public:
        int v;
        double R,C;
    };
    
    int n,m,S;
    double V;
    vector<Data> E[maxN];
    double Dist[maxN];
    bool inqueue[maxN];
    int Tot[maxN];
    queue<int> Q;
    
    int main()
    {
        while(cin>>n>>m>>S>>V)
        {
            for (int i=1;i<=n;i++)
                E[i].clear();
            for (int i=1;i<=m;i++)
            {
                int u,v;
                double Ruv,Cuv,Rvu,Cvu;
                cin>>u>>v>>Ruv>>Cuv>>Rvu>>Cvu;
                E[u].push_back((Data){v,Ruv,Cuv});
                E[v].push_back((Data){u,Rvu,Cvu});
            }
            memset(Dist,0,sizeof(Dist));
            memset(inqueue,0,sizeof(inqueue));
            memset(Tot,0,sizeof(Tot));
            while (!Q.empty())
                Q.pop();
            Dist[S]=V;
            Q.push(S);
            inqueue[S]=1;
            bool get=0;
            do
            {
                int u=Q.front();
                //cout<<u<<endl;
                //cout<<Dist[u]<<endl;
                Q.pop();
                inqueue[u]=0;
                Tot[u]++;
                if (Tot[u]>=n)
                {
                    get=1;
                    cout<<"YES"<<endl;
                    break;
                }
                for (int i=0;i<E[u].size();i++)
                {
                    int v=E[u][i].v;
                    double w=(Dist[u]-E[u][i].C)*E[u][i].R;
                    if (w>Dist[v])
                    {
                        Dist[v]=w;
                        if (inqueue[v]==0)
                        {
                            Q.push(v);
                            inqueue[v]=1;
                        }
                    }
                }
            }
            while (!Q.empty());
            if (get==0)
                cout<<"NO"<<endl;
        }
        return 0;
    }
    
  • 相关阅读:
    display
    盒子模型
    css样式
    修改页面标题前的图标
    form表单
    html中列表
    代码书写格式
    dw中的超链接
    硬盘的访问,程序重定位和加载
    Bochs调试指令
  • 原文地址:https://www.cnblogs.com/SYCstudio/p/7225498.html
Copyright © 2011-2022 走看看