zoukankan      html  css  js  c++  java
  • Digit Counting ( UVA

    Trung is bored with his mathematics homeworks. He takes a piece of chalk and starts writing a sequence of consecutive integers starting with 1 to N (1 < N < 10000). After that, he counts the number of times each digit (0 to 9) appears in the sequence. For example, with N = 13, the sequence is:
    12345678910111213
    In this sequence, 0 appears once, 1 appears 6 times, 2 appears 2 times, 3 appears 3 times, and each digit from 4 to 9 appears once. After playing for a while, Trung gets bored again. He now wants to write a program to do this for him. Your task is to help him with writing this program.
    Input
    The input file consists of several data sets. The first line of the input file contains the number of data sets which is a positive integer and is not bigger than 20. The following lines describe the data sets. For each test case, there is one single line containing the number N.
    Output
    For each test case, write sequentially in one line the number of digit 0,1,...9 separated by a space.
    Sample Input
    2 3 13
    Sample Output
    0 1 1 1 0 0 0 0 0 0 1 6 2 2 1 1 1 1 1 1

    #include <iostream>
    #include <cstring>
    using namespace std;
    int main()
    {
        int a[10],t,n;
        while(cin>>t)
        while(t--)
        {
            memset(a,0,sizeof(a));
            cin>>n;
            for(int i=1;i<=n;i++)
            {
                int ans=i;
                while(ans)
                {
                    int num=ans%10;
                    a[num]++;
                    ans/=10;
                }
            }
            cout<<a[0];
            for(int i=1;i<10;i++)
                cout<<" "<<a[i];
            cout<<endl;
        }
        return 0;
    }
    所遇皆星河
  • 相关阅读:
    mogodb优化
    uuid
    ssl详解
    探究rh6上mysql5.6的主从、半同步、GTID多线程、SSL认证主从复制
    CMAKE MYSQL
    证书生成
    叶金荣主页
    mysqlslap
    sysbench 测试MYSQL
    mysql实验室
  • 原文地址:https://www.cnblogs.com/Shallow-dream/p/11632249.html
Copyright © 2011-2022 走看看