zoukankan      html  css  js  c++  java
  • hdu acm 2673

    Problem Description
    Acmer in HDU-ACM team are ambitious, especially shǎ崽, he can spend time in Internet bar doing problems overnight. So many girls want to meet and Orz him. But Orz him is not that easy.You must solve this problem first.
    The problem is :
    Give you a sequence of distinct integers, choose numbers as following : first choose the biggest, then smallest, then second biggest, second smallest etc. Until all the numbers was chosen .
    For example, give you 1 2 3 4 5, you should output 5 1 4 2 3
     
    Input
    There are multiple test cases, each case begins with one integer N(1 <= N <= 10000), following N distinct integers.
     
    Output
    Output a sequence of distinct integers described above.
     
    Sample Input
    5
    1 2 3 4 5
     
    Sample Output
    5 1 4 2 3

    #include "iostream"
    #include "string.h"

    int digit[10005];

    int cmp(const void *a,const void *b)
    {
     return *((int *)a)-*((int *)b);
    }

    int main()
    {
     int n;

     while(scanf("%d",&n)==1)
     {
      memset(digit,0,sizeof(digit));

      for(int i=0;i<n;i++)
      {
       scanf("%d",&digit[i]);
      }

      qsort(digit,n,sizeof(int),cmp);

      for(int i=0;i<n/2;i++)
      {
       printf("%d %d",digit[n-i-1],digit[i]);
       if(i!=n/2-1)
        printf(" ");//注意空格
      }
      if(n%2!=0)
       printf(" %d",digit[n/2]);
       printf("\n");
     }
     return 0;
    }

     

  • 相关阅读:
    spring MVC的启动过程详解
    BeanFactory和applicationContext之间的区别
    spring的事务管理
    通用Mybatis的Crud搭建
    spring的IOC原理
    spring的AOP原理
    TortoiseSVN使用简介
    SVN简明教程
    POJO
    velocity 框架
  • 原文地址:https://www.cnblogs.com/Shirlies/p/2325010.html
Copyright © 2011-2022 走看看