zoukankan      html  css  js  c++  java
  • HDU

    It’s time to fight the local despots and redistribute the land. There is a rectangular piece of land granted from the government, whose length and width are both in binary form. As the mayor, you must segment the land into multiple squares of equal size for the villagers. What are required is there must be no any waste and each single segmented square land has as large area as possible. The width of the segmented square land is also binary.

    Input

    The first line of the input is T (1 ≤ T ≤ 100), which stands for the number of test cases you need to solve. 

    Each case contains two binary number represents the length L and the width W of given land. (0 < L, W ≤ 2 1000)

    Output

    For each test case, print a line “Case #t: ”(without quotes, t means the index of the test case) at the beginning. Then one number means the largest width of land that can be divided from input data. And it will be show in binary. Do not have any useless number or space.

    Sample Input

    3
    10 100
    100 110
    10010 1100

    Sample Output

    Case #1: 10
    Case #2: 10
    Case #3: 110

    代码:

    import java.io.BufferedInputStream;
    import java.math.BigInteger;
    import java.util.Scanner;
    
    public class Main {
    
    	public static void main(String[] args) {
    		// TODO 自动生成的方法存根
    		Scanner str = new Scanner(System.in);
    		int T;
    		T=str.nextInt();
    		int i=1;
    		
    
    		for(i=1;i<=T;i++)
    		{
    			String st,st1;
    			st=str.next();
    			st1=str.next();
    			BigInteger a=new BigInteger(st,2);
    			BigInteger b=new BigInteger(st1,2);
    			BigInteger c=a.gcd(b);
    			System.out.println("Case #"+i+": "+c.toString(2));
    			
    			
    		}
    
    	}
    
    }
    
  • 相关阅读:
    两层或以上的showModalDialog解决方法
    我想学什么技术该怎样学
    中英文颜色代码参考
    来个实时更新文本框关于某个项的值
    JavaScript操作XML(一)
    关于css中的position在各大浏览器(IE,FireFox,Opera)中表现问题
    兼容IE/FF的手动触发事件的函数
    兼容各主浏览器透明的CSS
    判断浏览器类型的脚本
    Meta标签详解
  • 原文地址:https://www.cnblogs.com/Staceyacm/p/10781750.html
Copyright © 2011-2022 走看看