zoukankan      html  css  js  c++  java
  • UVA

    Andy, 8, has a dream - he wants to produce his very own dictionary. This is not an easy task for him, as the number of words that he knows is, well, not quite enough. Instead of thinking up all the words himself, he has a briliant idea. From his bookshelf he would pick one of his favourite story books, from which he would copy out all the distinct words. By arranging the words in alphabetical order, he is done! Of course, it is a really time-consuming job, and this is where a computer program is helpful.

    You are asked to write a program that lists all the different words in the input text. In this problem, a word is defined as a consecutive sequence of alphabets, in upper and/or lower case. Words with only one letter are also to be considered.

    Furthermore, your program must be CaSe InSeNsItIvE. For example, words like “Apple”, “apple” or “APPLE” must be considered the same.
     

    Input


    The input file is a text with no more than 5000 lines. An input line has at most 200 characters. Input is terminated by EOF.
     

    Output


    Your output should give a list of different words that appears in the input text, one in a line. The words should all be in lower case, sorted in alphabetical order. You can be sure that he number of distinct words in the text does not exceed 5000.
     

    Sample Input


    Adventures in Disneyland
    Two blondes were going to Disneyland when they came to a fork in the road. The sign read: "Disneyland Left."
    So they went home.

    Sample Output


    a

    adventures

    blondes

    came

    disneyland

    fork

    going

    home

    in

    left

    read

    road

    sign

    so

    the

    they

    to

    two

    went

    were

    when

    题解:对于没有重复,我们很容易就想到了set,并且set是从小到大排序好的,对于对于多余的字符,我们可以利用空格来抹去

    然后都变成小写。

    接下来是代码:

    #include<cstdio>
    #include<iostream>
    #include<cstring>
    #include<algorithm>
    #include<sstream>
    #include<set>
    
    using namespace std;
    
    int main()
    {
    	set<string>dic;//建立一个类型为string型的集合
    
        string str , word;
        
        while(cin>>str)
        {
        	for(int t=0;t<str.length();t++)
        	{
        		if(isalpha(str[t]))
        		str[t]=tolower(str[t]);
        		else
        		str[t]=' ';
    		}
        	stringstream w(str);
        	while(w>>word)
        	dic.insert(word);
    	}
    	
    	 for(set<string>::iterator it=dic.begin();it!=dic.end();it++)
    	 {
    	 	
    	 	cout<<*it<<endl;
    	 }
    	
    	
    	return 0;
    }
  • 相关阅读:
    什么时候用resultMap,什么时候用resultType?
    Cannot create PoolableConnectionFactory解决思路
    去除list集合中重复项的几种方法-转载
    ORA-02298 定位问题
    命令行退出MySQL和登录MySQL
    CX4-480服务器数据恢复过程(服务器数据恢复通用方法)
    也谈腾讯云的静默损坏
    raid5阵列两块硬盘离线怎么解决
    服务器卷删除初检报告/数据恢复成功率分析
    服务器两块硬盘离线如何恢复数据
  • 原文地址:https://www.cnblogs.com/Staceyacm/p/10782091.html
Copyright © 2011-2022 走看看