zoukankan      html  css  js  c++  java
  • (STL初步)映射:map

    map就是从键(key)到值(value)的映射。

    因为重载了[]运算符,map像是数组的”高级版“。

    例如,map<string,int>month_name 表示:”月份名字到月份编号“的映射。

    赋值方式: month_name["July"]=7;(类似于 month_name["string"]=int )

    例题5-4

    Problem

    Most crossword puzzle fans are used to anagrams--groups of words with the same letters in different orders--for example OPTS, SPOT, STOP, POTS and POST. Some words however do not have this attribute, no matter how you rearrange their letters, you cannot form another word. Such words are called ananagrams, an example is QUIZ.

    Obviously such definitions depend on the domain within which we are working; you might think that ATHENE is an ananagram, whereas any chemist would quickly produce ETHANE. One possible domain would be the entire English language, but this could lead to some problems. One could restrict the domain to, say, Music, in which case SCALE becomes a relative ananagram (LACES is not in the same domain) but NOTE is not since it can produce TONE.

    Write a program that will read in the dictionary of a restricted domain and determine the relative ananagrams. Note that single letter words are, ipso facto, relative ananagrams since they cannot be ``rearranged'' at all. The dictionary will contain no more than 1000 words.

    Input

    Input will consist of a series of lines. No line will be more than 80 characters long, but may contain any number of words. Words consist of up to 20 upper and/or lower case letters, and will not be broken across lines. Spaces may appear freely around words, and at least one space separates multiple words on the same line. Note that words that contain the same letters but of differing case are considered to be anagrams of each other, thus tIeD and EdiT are anagrams. The file will be terminated by a line consisting of a single #.

    Output

    Output will consist of a series of lines. Each line will consist of a single word that is a relative ananagram in the input dictionary. Words must be output in lexicographic (case-sensitive) order. There will always be at least one relative ananagram.

    Sample input

    ladder came tape soon leader acme RIDE lone Dreis peat
    ScAlE orb  eye  Rides dealer  NotE derail LaCeS  drIed
    noel dire Disk mace Rob dries
    #

    Sample output

    Disk
    NotE
    derail
    drIed
    eye
    ladder
    soon

    题意:输入一些单词,找出满足如下条件的单词:该单词不能通过字母重排,得到输入文本中的另外一个单词。在判断是否满足条件时,字母不分大小写。但在输出时应保留输入中的大小写,按字典序进行排列(所有大写字母在所有小写字母的前面)。

    Analyse

     把每个单词“标准化”,即全部转化为小写字母后再进行排序,然后再放到map中进行统计。

    #include<cstdio>
    #include<string>
    #include<cctype>
    #include<iostream>
    #include<vector>
    #include<map>
    #include<algorithm>
    using namespace std;
    
    map<string,int> cnt;
    vector<string> words;
    
    //将单词s进行“标准化”
    string repr(const string& s)
    {
        string ans=s;
        for(int i=0;i<ans.length();i++)
            ans[i]=tolower(ans[i]);  //tolower()函数,把字符转换成小写字母,非字母字符不做出处理。头文件为ctype.h。
        sort(ans.begin(),ans.end());
        return ans;
    }
    
    int main()
    {
        int n=0;
        string s;
        while(cin>>s)
        {
            if(s[0]=='#')
                break;
            words.push_back(s); //把单词一个个存储在vector定义的不定长数组words中
            string r=repr(s);   //调用repr()函数,通过引用,返回一个"标准化"的单词
            if(!cnt.count(r))  //count()函数只能返回0(不存在)或者1(存在)。返回指定元素的次数。
                cnt[r]=0;
            cnt[r]++;
        }
        vector<string> ans;
        for(int i=0;i<words.size();i++)
            if(cnt[repr(words[i])]==1)
                ans.push_back (words[i]);
        sort(ans.begin(),ans.end());
        for(int i=0;i<ans.size();i++)
            cout<<ans[i]<<'
    ';
        return 0;
    }
  • 相关阅读:
    C#基于LibUsbDotNet实现USB通信(一)
    Visual Studio 删除空行
    不安全代码只会在使用 /unsafe 编译的情况下出现
    VS2013 中 CString类型转换为LPCSTR类型
    Linux 下各文件夹的含义
    每日算法---Two Sum
    跟我一步一步写出MongoDB Web 可视化工具(二)
    跟我一步一步写出MongoDB Web 可视化工具(一)
    springcloud 微服务之间传递token解决方案
    Git设定不合并的文件
  • 原文地址:https://www.cnblogs.com/Strugglinggirl/p/5994141.html
Copyright © 2011-2022 走看看