zoukankan      html  css  js  c++  java
  • 畅通工程续

    Description

    某省自从实行了很多年的畅通工程计划后,终于修建了很多路。不过路多了也不好,每次要从一个城镇到另一个城镇时,都有许多种道路方案可以选择,而某些方案要比另一些方案行走的距离要短很多。这让行人很困扰。

    现在,已知起点和终点,请你计算出要从起点到终点,最短需要行走多少距离。
     

    Input

    本题目包含多组数据,请处理到文件结束。
    每组数据第一行包含两个正整数N和M(0<N<200,0<M<1000),分别代表现有城镇的数目和已修建的道路的数目。城镇分别以0~N-1编号。
    接下来是M行道路信息。每一行有三个整数A,B,X(0<=A,B<N,A!=B,0<X<10000),表示城镇A和城镇B之间有一条长度为X的双向道路。
    再接下一行有两个整数S,T(0<=S,T<N),分别代表起点和终点。
     

    Output

    对于每组数据,请在一行里输出最短需要行走的距离。如果不存在从S到T的路线,就输出-1.
     

    Sample Input

    3 3
    0 1 1
    0 2 3
    1 2 1
    0 2
    3 1
    0 1 1
    1 2

    Sample Output

    2
    -1
     
     
    //最坑的是读入数据的时候:a到b能不给出一组数据而已。所以要选择最小的来保存在road[a][b]中。
     
    #include <iostream>
    #include <cstring>
    #define maxDis 999999999
    using namespace std;
    int road[205][205];
    int dis[205];
    bool visit[205];
    int minLength(int s,int t,int n)
    {
        for(int i = 0 ; i < n; i++)
        {
            visit[i] = false;
            dis[i] = 0;
        }
        for(int i = 0 ; i < n; i++)
        {
            dis[i] = road[s][i];
        }
        dis[s] = 0;
        visit[s] = true;
        for(int i = 0 ; i < n; i++)
        {
            int min = maxDis;
            int index = 0;
            for(int j = 0 ; j < n; j++)
            {
                if(!visit[j] && dis[j] < min)
                {
                    min = dis[j];
                    index = j;
                }
            }
            visit[index] = true;
            for(int j = 0 ; j < n; j++)
            {
                if(!visit[j] && road[index][j] < maxDis && dis[index] + road[index][j] < dis[j])
                {
                    dis[j] = dis[index] + road[index][j];
                }
            }
        }
    	if(dis[t] <  maxDis)
    		return dis[t];
    	else
    		return -1;
    }
    int main()
    {
    	int n,m;
    	while(cin>>n>>m)
    	{
    		for(int i = 0 ; i < n; i++)
    		{
    			for(int j = 0 ; j < n; j++)
    			{
    			    if(i == j)
    			    {
    			        road[i][j] = 0;
    			    }
    			    else
                     road[i][j] = maxDis;
    			}
    		}
    		int a,b,x;
    		for(int i = 0 ; i < m ;i++)
    		{
    			cin>>a>>b>>x;//选择最小的数据来保存。。。。
    			if (road[a][b]>x)
    			{
    			    road[a][b] = x;
    			    road[b][a] = x;
    			}
    
    		}
    		int s,t;
    		cin>>s>>t;
    		if(s == t)
    		{
    		    cout<<0<<endl;
    		}
    		else
    		{
    		    if(s > t)
    		    {
    		        cout<<minLength(s,t,n)<<endl;
    		    }
    		    else
    		    {
    		        cout<<minLength(t,s,n)<<endl;
    		    }
    		}
    	}
    	return 0;
    }
  • 相关阅读:
    Java面试题
    删除两个相同的数据
    Oracle中的rowid rownum
    SQL的七种连接
    Oracle的分页和MySQL的分页
    Script to Collect Log File Sync Diagnostic Information (lfsdiag.sql) (文档 ID 1064487.1)
    Analytic Functions in Oracle
    Oracle X$Tables
    Microsoft SQL Server Trace Flags
    Oracle Log Block Size
  • 原文地址:https://www.cnblogs.com/T8023Y/p/3242978.html
Copyright © 2011-2022 走看看