zoukankan      html  css  js  c++  java
  • HDU-1017

    A Mathematical Curiosity

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

    Problem Description

    Given two integers n and m, count the number of pairs of integers (a,b) such that 0 < a < b < n and (a^2+b^2 +m)/(ab) is an integer.
    This problem contains multiple test cases!
    The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.
    The output format consists of N output blocks. There is a blank line between output blocks.

    Input
    You will be given a number of cases in the input. Each case is specified by a line containing the integers n and m. The end of input is indicated by a case in which n = m = 0. You may assume that 0 < n <= 100.
     
    Output
    For each case, print the case number as well as the number of pairs (a,b) satisfying the given property. Print the output for each case on one line in the format as shown below.
     
    Sample Input
    1
    10 1
    20 3
    30 4
    0 0
     
    Sample Output
    Case 1: 2
    Case 2: 4
    Case 3: 5
     
    Source
     
    题解:给定一个N,表示有N组测试数据。每组测试数据中每次给定n 和 m。当n = m = 0时结束本组测试数据。得到n 和m 之后,需要计算令(a ^ 2 + b ^ 2 + m) / (ab) 为整数的a, b的组数。。a, b满足(0 < a < b < n)。(注意格式问题,容易出现PE)
     
    代码:
    #include<iostream>
    using namespace std;
    int n,m,sum,t,k;
    int main()
    {
        cin>>t;
        while(t--)
        {
            k=0;
            while(cin>>n>>m)
            {
                if(n==0&&m==0)
                    break;
                sum=0;
                for(int i=1;i<n;i++)
                    for(int j=i+1;j<n;j++)
                    {
                        int temp=i*i+j*j+m;    
                        int flag=i*j;
                        if(temp%flag==0)          //测试为整数
                            sum++;
                    }
                cout<<"Case"<<" "<<++k<<": "<<sum<<endl;
            }
            if(t!=0)
                cout<<endl;       //不是最后一行就需要空格
        }
      return 0;
    }
  • 相关阅读:
    培训课程大纲
    十个心理细节
    海马记忆训练
    手把手教你_怎么找android应用的包名和启动activity
    LoaderManager使用具体解释(四)---实例:AppListLoader
    strtok函数
    猫猫学iOS 之微博项目实战(2)微博主框架-自己定义导航控制器NavigationController
    OpenCV实践之路——Python的安装和使用
    状态模式
    一个有意思的Ruby Webdriver超时问题的解决过程
  • 原文地址:https://www.cnblogs.com/Tangent-1231/p/8067445.html
Copyright © 2011-2022 走看看