zoukankan      html  css  js  c++  java
  • [解题报告]102 Ecological Bin Packing

     

     Ecological Bin Packing 

    Background

    Bin packing, or the placement of objects of certain weights into different bins subject to certain constraints, is an historically interesting problem. Some bin packing problems are NP-complete but are amenable to dynamic programming solutions or to approximately optimal heuristic solutions.

    In this problem you will be solving a bin packing problem that deals with recycling glass.

    The Problem

    Recycling glass requires that the glass be separated by color into one of three categories: brown glass, green glass, and clear glass. In this problem you will be given three recycling bins, each containing a specified number of brown, green and clear bottles. In order to be recycled, the bottles will need to be moved so that each bin contains bottles of only one color.

    The problem is to minimize the number of bottles that are moved. You may assume that the only problem is to minimize the number of movements between boxes.

    For the purposes of this problem, each bin has infinite capacity and the only constraint is moving the bottles so that each bin contains bottles of a single color. The total number of bottles will never exceed 2^31.

    The Input

    The input consists of a series of lines with each line containing 9 integers. The first three integers on a line represent the number of brown, green, and clear bottles (respectively) in bin number 1, the second three represent the number of brown, green and clear bottles (respectively) in bin number 2, and the last three integers represent the number of brown, green, and clear bottles (respectively) in bin number 3. For example, the line 10 15 20 30 12 8 15 8 31

    indicates that there are 20 clear bottles in bin 1, 12 green bottles in bin 2, and 15 brown bottles in bin 3.

    Integers on a line will be separated by one or more spaces. Your program should process all lines in the input file.

    The Output

    For each line of input there will be one line of output indicating what color bottles go in what bin to minimize the number of bottle movements. You should also print the minimum number of bottle movements.

    The output should consist of a string of the three upper case characters 'G', 'B', 'C' (representing the colors green, brown, and clear) representing the color associated with each bin.

    The first character of the string represents the color associated with the first bin, the second character of the string represents the color associated with the second bin, and the third character represents the color associated with the third bin.

    The integer indicating the minimum number of bottle movements should follow the string.

    If more than one order of brown, green, and clear bins yields the minimum number of movements then the alphabetically first string representing a minimal configuration should be printed.

    Sample Input

    1 2 3 4 5 6 7 8 9
    5 10 5 20 10 5 10 20 10

    Sample Output

    BCG 30
    CBG 50




    每一个箱子都要拿出两种颜色的物体交换出去,那么总个数减去留下来的那一个颜色的物体个数即交换数


    #include<stdio.h>
    int main()
    {
    long a[3],b[3],c[3],sum,n[6]={0},i,j,m;
    while(scanf("%ld%ld%ld%ld%ld%ld%ld%ld%ld",&a[0],&a[1],&a[2],&b[0],&b[1],&b[2],&c[0],&c[1],&c[2])!=EOF)
                {sum=a[0]+a[1]+a[2]+b[0]+b[1]+b[2]+c[0]+c[1]+c[2];
                n[0]=a[0]+b[2]+c[1];
                n[1]=a[0]+b[1]+c[2];
                n[2]=a[2]+b[0]+c[1];
                n[3]=a[2]+b[1]+c[0];
                n[4]=a[1]+b[0]+c[2];
                n[5]=a[1]+b[2]+c[0];
                for(j=m=i=0;i<6;i++)
                if(n[i]>m){
                           m=n[i];
                           j=i+1;
                           }
                switch(j)
                           {
                           case 1: printf("BCG %ld\n",sum-n[0]);break;
                           case 2: printf("BGC %ld\n",sum-n[1]);break;
                           case 3: printf("CBG %ld\n",sum-n[2]);break;
                           case 4: printf("CGB %ld\n",sum-n[3]);break;
                           case 5: printf("GBC %ld\n",sum-n[4]);break;
                           case 6: printf("GCB %ld\n",sum-n[5]);break;
                           }
                }
    return 0;
        }
  • 相关阅读:
    java发送邮件
    MySQL查询表结构的SQL语句
    Jquery的toggle()方法
    jQuery为图片添加链接(创建新的元素来包裹选中的元素)
    mysql修改存储过程的权限
    php中接收参数,不论是来自GET还是POST方法
    解决php中文乱码
    MySQL的视图view,视图创建后,会随着表的改变而自动改变数据
    选项卡面向对象练习
    对数组的操作splice() 和slice() 用法和区别
  • 原文地址:https://www.cnblogs.com/TheLaughingMan/p/2890013.html
Copyright © 2011-2022 走看看