zoukankan      html  css  js  c++  java
  • [解题报告]299 Train Swapping

     Train Swapping 

    At an old railway station, you may still encounter one of the last remaining ``train swappers''. A train swapper is an employee of the railroad, whose sole job it is to rearrange the carriages of trains.

    Once the carriages are arranged in the optimal order, all the train driver has to do, is drop the carriages off, one by one, at the stations for which the load is meant.

    The title ``train swapper'' stems from the first person who performed this task, at a station close to a railway bridge. Instead of opening up vertically, the bridge rotated around a pillar in the center of the river. After rotating the bridge 90 degrees, boats could pass left or right.

    The first train swapper had discovered that the bridge could be operated with at most two carriages on it. By rotating the bridge 180 degrees, the carriages switched place, allowing him to rearrange the carriages (as a side effect, the carriages then faced the opposite direction, but train carriages can move either way, so who cares).

    Now that almost all train swappers have died out, the railway company would like to automate their operation. Part of the program to be developed, is a routine which decides for a given train the least number of swaps of two adjacent carriages necessary to order the train. Your assignment is to create that routine.

    Input Specification

    The input contains on the first line the number of test cases (N). Each test case consists of two input lines. The first line of a test case contains an integer L, determining the length of the train ( tex2html_wrap_inline30). The second line of a test case contains a permutation of the numbers 1 through L, indicating the current order of the carriages. The carriages should be ordered such that carriage 1 comes first, then 2, etc. with carriage L coming last.

    Output Specification

    For each test case output the sentence: 'Optimal train swapping takes S swaps.' where S is an integer.

    Example Input

    3
    3
    1 3 2
    4
    4 3 2 1
    2
    2 1

    Example Output

    Optimal train swapping takes 1 swaps.
    Optimal train swapping takes 6 swaps.
    Optimal train swapping takes 1 swaps.



    当你把题目看了N遍发现就是让你统计冒泡排序的次数的时候,想必你也只能呵呵吧。。。。。。

    #include<stdio.h>
    int main()
    {
        int N;
        scanf("%d",&N);
        while(N--)
        {
            int i;
            scanf("%d",&i);
            int a[100]={0};
            int k,j,count=0,temp;
            for(k=0;k<i;k++) scanf("%d",&a[k]);
            for(k=0;k<i-1;k++)
             {
                 for(j=0;j<i-1-k;j++)
              {
                  if(a[j]>a[j+1])
                  {
                     temp=a[j];
                     a[j]=a[j+1];
                     a[j+1]=temp;
                     count++;
                  }
              }
             }
             printf("Optimal train swapping takes %d swaps.\n",count);
        }
        return 0;
    }
  • 相关阅读:
    分布式系统阅读笔记(六)-----间接通信
    分布式系统阅读笔记(六)-----间接通信
    分布式系统阅读笔记(六)-----间接通信
    分布式系统阅读笔记(七)-----操作系统的支持
    分布式系统阅读笔记(七)-----操作系统的支持
    分布式系统阅读笔记(七)-----操作系统的支持
    分布式系统阅读笔记(八)-----分布式对象和组件
    sizeof()
    void *
    strcpy函数的实现
  • 原文地址:https://www.cnblogs.com/TheLaughingMan/p/2919729.html
Copyright © 2011-2022 走看看