zoukankan      html  css  js  c++  java
  • [解题报告]575 Skew Binary

      Skew Binary 

    When a number is expressed in decimal, the k-th digit represents a multiple of 10k. (Digits are numbered from right to left, where the least significant digit is number 0.) For example, 

    \begin{displaymath}81307_{10} = 8 \times 10^4 + 1 \times 10^3 + 3 \times 10^2 + ...
...mes 10^1 +
7 \times 10 0 = 80000 + 1000 + 300 + 0 + 7
= 81307.
\end{displaymath}

    When a number is expressed in binary, the k-th digit represents a multiple of 2k. For example, 

    \begin{displaymath}10011_2 = 1 \times 2^4 + 0 \times 2^3 + 0 \times 2^2 + 1 \times 2^1 +
1 \times 2^0 = 16 + 0 + 0 + 2 + 1 = 19.
\end{displaymath}

    In skew binary, the k-th digit represents a multiple of 2k+1 - 1. The only possible digits are 0 and 1, except that the least-significant nonzero digit can be a 2. For example, 

    \begin{displaymath}10120_{skew} = 1 \times (2^5 - 1) + 0 \times (2^4-1) + 1 \tim...
...2 \times (2^2-1) + 0 \times (2^1-1)
= 31 + 0 + 7 + 6 + 0 = 44.
\end{displaymath}

    The first 10 numbers in skew binary are 0, 1, 2, 10, 11, 12, 20, 100, 101, and 102. (Skew binary is useful in some applications because it is possible to add 1 with at most one carry. However, this has nothing to do with the current problem.)

    Input 

    The input file contains one or more lines, each of which contains an integer n. If n = 0 it signals the end of the input, and otherwise n is a nonnegative integer in skew binary.

    Output 

    For each number, output the decimal equivalent. The decimal value of n will be at most 231 - 1 = 2147483647.

    Sample Input 

    10120
    200000000000000000000000000000
    10
    1000000000000000000000000000000
    11
    100
    11111000001110000101101102000
    0
    

    Sample Output 

    44
    2147483646
    3
    2147483647
    4
    7
    1041110737
    

    Miguel A. Revilla 
    1998-03-10
     
     
     
     
    略水,注意计算细节
    #include<stdio.h>
    #include<math.h>
    #include<string.h>
    int main()
    {
        char n[50];
        while(scanf("%s",n)!=EOF&&n[0]!='0')
        {
          unsigned m=0;
          int i,j;
          j=strlen(n);
          for(i=0;i<j;i++)
          {
              m+=(n[i]-'0')*(pow(2,j-i)-1);
          }
         printf("%u\n",m);
        }
        return 0;
    }
  • 相关阅读:
    Photoshop CC 与前端那些事
    gulp入門指南
    谈谈css左右等高的几个方法
    angularjs给Model添加拦截过滤器,路由增加限制,实现用户登录状态判断
    前端自动化工具
    React Router
    Sublime Text 3 常用插件安装
    c++ primer学习指导(13)--1.6书店程序
    c++ primer学习指导(12)--1.5.2初识成员函数
    c++ primer学习指导(11)--1.5.1Sales_item类
  • 原文地址:https://www.cnblogs.com/TheLaughingMan/p/2922939.html
Copyright © 2011-2022 走看看