zoukankan      html  css  js  c++  java
  • [解题报告]530 Binomial Showdown

      Binomial Showdown 

    In how many ways can you choose k elements out of n elements, not taking order into account?

    Write a program to compute this number.

    Input Specification 

    The input file will contain one or more test cases.

    Each test case consists of one line containing two integers n ($n \ge 1$) and k ( $0 \le k \le n$).

    Input is terminated by two zeroes for n and k.

    Output Specification 

    For each test case, print one line containing the required number. This number will always fit into an integer, i.e. it will be less than 231.


    Warning: Don't underestimate the problem. The result will fit into an integer - but if all intermediate results arising during the computation will also fit into an integer depends on your algorithm. The test cases will go to the limit.

    Sample Input 

    4 2
    10 5
    49 6
    0 0
    

    Sample Output 

    6
    252
    13983816



    排列组合嘛。。。注意数据类型

    #include<stdio.h>
    int main()
    {
        int a,b,n,m;
        double s;
        while(scanf("%d %d",&n,&m)!=EOF)
        {
            if(n==0) break;
            if(m>n/2) m=n-m;
            for(a=1,b=n,s=1;a<=m;a++,b--)
            {
             s=s*b;
             s=s/a;
            }
            printf("%.0lf\n",s);
        }
        return 0;
    }
    
    
  • 相关阅读:
    纯js实现字符串formate方法
    C#实现json压缩和格式化
    简单的前端校验框架实现
    快速拷贝文件
    0012 移除元素
    0011 删除链表的倒数第N个节点
    0010 最长公共前缀
    0009 合并两个有序链表
    0008 合并K个排序链表
    0007 回文数
  • 原文地址:https://www.cnblogs.com/TheLaughingMan/p/2932110.html
Copyright © 2011-2022 走看看