zoukankan      html  css  js  c++  java
  • [解题报告]10340 All in All

    Problem E

    All in All

    Input: standard input

    Output: standard output

    Time Limit: 2 seconds

    Memory Limit: 32 MB

    You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string.

    Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s.

    Input Specification

    The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace. Input is terminated by EOF.

    Output Specification

    For each test case output, if s is a subsequence of t.

    Sample Input

    sequence subsequence
    person compression
    VERDI vivaVittorioEmanueleReDiItalia
    caseDoesMatter CaseDoesMatter

    Sample Output

    Yes
    No
    Yes
    No

    Source: ULM Local Contest

    字符遍历查找,不难

    #include<stdio.h>
    #include<string.h>
    char s[100000],t[100000];
    int main()
    {
        int i,j,k1,k2;
        while(scanf("%s%s",s,t)==2)
        {
            k1=strlen(s);
            k2=strlen(t);
            if(k1>=k2)
            {
                printf("No\n");
                continue;
            }
            for(i=0,j=0;t[j]!='\0'&&i<k1;j++)
            {
                if(k1-i>k2-j)
                    break;
                if(s[i]==t[j])
                    i++;
            }
            if(i==k1)
                printf("Yes\n");
            else
                printf("No\n");
        }
        return 0;
    }
  • 相关阅读:
    套题 8.22
    套题 8.21
    P1042 乒乓球
    套题8.20
    #52. 【UR #4】元旦激光炮 (交互式题)
    #82. 【UR #7】水题生成器
    度度熊与邪恶大魔王
    wpf 获取image控件的图片并保存
    wpf 让正执行的程序暂停几秒钟
    wpf问题集锦
  • 原文地址:https://www.cnblogs.com/TheLaughingMan/p/2932153.html
Copyright © 2011-2022 走看看