zoukankan      html  css  js  c++  java
  • [解题报告]HDU 1170 Balloon Comes!

    Balloon Comes!

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 16376    Accepted Submission(s): 5958


    Problem Description
    The contest starts now! How excited it is to see balloons floating around. You, one of the best programmers in HDU, can get a very beautiful balloon if only you have solved the very very very... easy problem.
    Give you an operator (+,-,*, / --denoting addition, subtraction, multiplication, division respectively) and two positive integers, your task is to output the result. 
    Is it very easy? 
    Come on, guy! PLMM will send you a beautiful Balloon right now!
    Good Luck!
     
    Input
    Input contains multiple test cases. The first line of the input is a single integer T (0<T<1000) which is the number of test cases. T test cases follow. Each test case contains a char C (+,-,*, /) and two integers A and B(0<A,B<10000).Of course, we all know that A and B are operands and C is an operator. 
     
    Output
    For each case, print the operation result. The result should be rounded to 2 decimal places If and only if it is not an integer.
     
    Sample Input
    4 + 1 2 - 1 2 * 1 2 / 1 2
     
    Sample Output
    3 -1 2 0.50
     
    Author
    lcy
     

    注意空格吸收,类型转换

    #include<stdio.h>
    int main()
    {
        int t,a,b;
        char m[2];
        scanf("%d",&t);
        while(t--)
        {
            scanf("%s%d%d",m,&a,&b);
            if(m[0]=='+') printf("%d\n",a+b);
            else if(m[0]=='-') printf("%d\n",a-b);
            else if(m[0]=='*') printf("%d\n",a*b);
            else if(a/b*b==a) printf("%d\n",a/b);
            else printf("%.2f\n",(double)a/b);
        }
        return 0;
    }
  • 相关阅读:
    面试题58 二叉树的下一个结点
    面试题57 删除链表中重复的结点
    面试题56 链表中环的入口结点
    面试题55 字符流中第一个不重复的字符
    面试题54 表示数值的字符串
    面试题50 树中两个结点的最低公共祖先
    面试题53 正则表达式匹配
    面试题52 构建乘积数组
    面试题51 数组中重复的数字
    Qt链接库出错version Qt_5 not defined
  • 原文地址:https://www.cnblogs.com/TheLaughingMan/p/3104336.html
Copyright © 2011-2022 走看看