zoukankan      html  css  js  c++  java
  • HDOJ-1251 字典树

      

    统计难题

    Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131070/65535 K (Java/Others)
    Total Submission(s): 25059    Accepted Submission(s): 10287


    Problem Description
    Ignatius最近遇到一个难题,老师交给他很多单词(只有小写字母组成,不会有重复的单词出现),现在老师要他统计出以某个字符串为前缀的单词数量(单词本身也是自己的前缀).
     

    Input
    输入数据的第一部分是一张单词表,每行一个单词,单词的长度不超过10,它们代表的是老师交给Ignatius统计的单词,一个空行代表单词表的结束.第二部分是一连串的提问,每行一个提问,每个提问都是一个字符串.

    注意:本题只有一组测试数据,处理到文件结束.
     

    Output
    对于每个提问,给出以该字符串为前缀的单词的数量.
     

    Sample Input
    banana band bee absolute acm ba b band abc
     

    Sample Output
    2 3 1 0
     

    Author
    Ignatius.L
     

     字典树模板题,没什么好说的,不过奇怪的是我用g++提交就会超内存,而用c++则AC,好惊悚。

    #include<iostream>
    #include<cstdio>
    #include<string>
    #include<cstring>
    using namespace std;
    #define MAX 26
    char CH='a';
    struct node{
        int key;
        node *next[MAX];
        node(){
            key=0;
            for(int i=0;i<MAX;i++)
                next[i]=NULL;
        }
    };
    node *root;
    void tireInsert(char* str){
        node*p=root,*q;
        for(int i=0;str[i];i++){
            int id=str[i]-CH;
            if(!p->next[id])
               p->next[id]=new node();
               p=p->next[id];
               p->key++;
        }
    }
    void dell(node*p)
    {
        if(p){
            for(int i=0;i<MAX;i++)
            if(p->next[i]){
                dell(p->next[i]);
                delete p->next[i];
            }
        }
    }
    int tireFind(char *str)
    {
        node *p=root;
        for(int i=0;str[i];i++){
            int id=str[i]-CH;
            p=p->next[id];
            if(!p)return 0;
        }
        return p->key;
    }
    int main()
    {
      char str[11];
      root=new node();
      while(gets(str),*str)tireInsert(str);
      while(gets(str))cout<<tireFind(str)<<endl;
    }
    

    版权声明:本文为博主原创文章,未经博主允许不得转载。

  • 相关阅读:
    cct,web技术
    cct信息安全
    TFS2010安装与管理
    centos7 opera济览器安装
    Hadoop 的常用组件一览
    Exception in thread "main" java.net.BindException: Address already in use: JVM_Bind
    gcc manual
    5350.support
    meminfo,df,
    WCF
  • 原文地址:https://www.cnblogs.com/Thereisnospon/p/4768464.html
Copyright © 2011-2022 走看看