zoukankan      html  css  js  c++  java
  • HDOJ 1509 Windows Message Queue

    Windows Message Queue

    Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
    Total Submission(s) : 7   Accepted Submission(s) : 3

    Font: Times New Roman | Verdana | Georgia

    Font Size:  

    Problem Description

    Message queue is the basic fundamental of windows system. For each process, the system maintains a message queue. If something happens to this process, such as mouse click, text change, the system will add a message to the queue. Meanwhile, the process will do a loop for getting message from the queue according to the priority value if it is not empty. Note that the less priority value means the higher priority. In this problem, you are asked to simulate the message queue for putting messages to and getting message from the message queue.

    Input

    There's only one test case in the input. Each line is a command, "GET" or "PUT", which means getting message or putting message. If the command is "PUT", there're one string means the message name and two integer means the parameter and priority followed by. There will be at most 60000 command. Note that one message can appear twice or more and if two messages have the same priority, the one comes first will be processed first.(i.e., FIFO for the same priority.) Process to the end-of-file.

    Output

    For each "GET" command, output the command getting from the message queue with the name and parameter in one line. If there's no message in the queue, output "EMPTY QUEUE!". There's no output for "PUT" command.

    Sample Input

    GET
    PUT msg1 10 5
    PUT msg2 10 4
    GET
    GET
    GET
    

    Sample Output

    EMPTY QUEUE!
    msg2 10
    msg1 10
    

    EMPTY QUEUE!

    优先队列模板题,不解释

    #include<iostream>
    #include<queue>
    #include<string>
    using namespace std;
    struct node
    {
        string name;
        int par;
        int pri;
        int ran;
        node(string _name,int _par,int _pri,int _ran):name(_name),par(_par),pri(_pri),ran(_ran){}
        node(){}
        friend bool operator <(node a,node b)
        {
            if(a.pri!=b.pri)
                return a.pri>b.pri;
            else return a.ran>b.ran;
        }
    };
    int main()
    {
        priority_queue<node>p;
        string cmd,name;
        int pri,par,ran=0;
        while(cin>>cmd)
        {
            ran++;
            if(cmd=="GET")
            {
                if(p.empty())
                    cout<<"EMPTY QUEUE!"<<endl;
                else
                {
                    node t=p.top();p.pop();
                    cout<<t.name<<" "<<t.par<<endl;
                }
            }
            else if(cmd=="PUT")
            {
                cin>>name>>par>>pri;
                p.push(node(name,par,pri,ran));
            }
        }
        return 0;
    }
    


    版权声明:本文为博主原创文章,未经博主允许不得转载。

  • 相关阅读:
    22个免费和高级WordPress的滑块插件
    asp.net mvc 4.0的部署
    苹果公布2011年度最佳iOS应用
    18 个 jQuery Mobile 开发贴士和教程
    给asp.net mvc小白扫盲用的
    JM8.6中的MV计算及上层块预测方法
    CAVLC算法解析
    JM8.6中的关于写比特流的问题
    JM8.6中对cofAC及相关数组的探讨
    JM8.6中三个RDCost函数的对比分析
  • 原文地址:https://www.cnblogs.com/Thereisnospon/p/4768484.html
Copyright © 2011-2022 走看看