zoukankan      html  css  js  c++  java
  • Ace of Aces

    http://acm.zju.edu.cn/onlinejudge/showContestProblems.do?contestId=362
    Ace of Aces

    Time Limit: 2 Seconds      Memory Limit: 65536 KB

    There is a mysterious organization called Time-Space Administrative Bureau (TSAB) in the deep universe that we humans have not discovered yet. This year, the TSAB decided to elect an outstanding member from its elite troops. The elected guy will be honored with the title of "Ace of Aces".

    After voting, the TSAB received N valid tickets. On each ticket, there is a number Ai denoting the ID of a candidate. The candidate with the most tickets nominated will be elected as the "Ace of Aces". If there are two or more candidates have the same number of nominations, no one will win.

    Please write program to help TSAB determine who will be the "Ace of Aces".

    Input

    There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

    The first line contains an integer N (1 <= N <= 1000). The next line contains N integers Ai (1 <= Ai <= 1000).

    Output

    For each test case, output the ID of the candidate who will be honored with "Ace of Aces". If no one win the election, output "Nobody" (without quotes) instead.

    Sample Input

    3
    5
    2 2 2 1 1
    5
    1 1 2 2 3
    1
    998
    

    Sample Output

    2
    Nobody
    998




    #include<stdio.h>
    #include<iostream>
    #include<algorithm>

    using namespace std;

    #define N 1010

    struct node
    {
        int a, b;
    }P[N];

    bool cmp(node a, node b)
    {
        return a.a < b.a;
    }
    int main()
    {
        int i, t, n, num;

        scanf("%d", &t);

        while(t--)
        {
            scanf("%d", &n);

            for(i = 0; i < N; i++)
                P[i].a = 0;

            for(i = 1; i <= n; i++)
            {
                scanf("%d", &num);
                P[num].a++;
            }

            if(n == 1)
                printf("%d", num);
            else
            {
                for(i = 1; i < 1010; i++)
                    P[i].b = i;

                sort(P, P+1010, cmp);

                if(P[1009].a == P[1008].a)
                    printf("Nobody");
                else
                    printf("%d", P[1009].b);
            }
            printf(" ");
        }
        return 0;
    }


    写了不知多久还是没写出来。。脑袋不清晰的时候该干嘛干嘛~
    想东西的时候一定要想东西
    让未来到来 让过去过去
  • 相关阅读:
    RabbitMQ学习系列二:.net 环境下 C#代码使用 RabbitMQ 消息队列
    越狱Season 1- Episode 22: Flight
    越狱Season 1-Episode 21: Go
    越狱Season 1-Episode 20: Tonight
    越狱Season 1-Episode 19: The Key
    越狱Season 1- Episode 18: Bluff
    越狱Season 1-Episode 17: J-Cat
    越狱Season 1- Episode 16
    越狱Season 1-Episode 15: By the Skin and the Teeth
    越狱Season 1-Episode 14: The Rat
  • 原文地址:https://www.cnblogs.com/Tinamei/p/4457375.html
Copyright © 2011-2022 走看看