zoukankan      html  css  js  c++  java
  • pat 1093. Count PAT's (25)

    1093. Count PAT's (25)

    时间限制
    120 ms
    内存限制
    65536 kB
    代码长度限制
    16000 B
    判题程序
    Standard
    作者
    CAO, Peng

    The string APPAPT contains two PAT's as substrings. The first one is formed by the 2nd, the 4th, and the 6th characters, and the second one is formed by the 3rd, the 4th, and the 6th characters.

    Now given any string, you are supposed to tell the number of PAT's contained in the string.

    Input Specification:

    Each input file contains one test case. For each case, there is only one line giving a string of no more than 105 characters containing only P, A, or T.

    Output Specification:

    For each test case, print in one line the number of PAT's contained in the string. Since the result may be a huge number, you only have to output the result moded by 1000000007.

    Sample Input:
    APPAPT
    
    Sample Output:
    2
    解:dp法,P[i]表示 到i位置前P的个数;PA[i]表示 到i位置前PA的个数;PAT[i]表示 到i位置前PAT的个数,状态转移条件代码里。

    代码:

    #include<iostream>
    #include<cstdlib>
    #include<cstdio>
    #include<cstring>
    using namespace std;
    int main()
    {
        string s;
        cin>>s;
        int len=s.length();
        int *P=new int[len+10];
        int *PA=new int[len+10];
        int *PAT=new int[len+10];
        memset(P,0,sizeof(P));
        memset(PA,0,sizeof(PA));
        memset(PAT,0,sizeof(PAT));
        for(int i=0;i<len;i++)
        {
            if(s[i]=='P')
            {
                if(i==0)
                    P[i]=1;
                else
                    P[i]=P[i-1]+1;
            }
            else
            {
               if(i==0) P[i]=0;
               else P[i]=P[i-1];
            }
        }
        for(int i=0;i<len;i++)
        {
            if(s[i]=='A'&&P[i]!=0)
            {
                if(i==0)
                    PA[i]=1;
                else
                {
                    PA[i]=PA[i-1]+P[i];
                    PA[i]%=1000000007;       
                }
            }
            else
            {
               if(i==0) PA[i]=0;
               else PA[i]=PA[i-1];
            }
        }
        for(int i=0;i<len;i++)
        {
            if(s[i]=='T'&&PA[i]!=0)
            {
                if(i==0)
                    PAT[i]=1;
                else
                 {
                    PAT[i]=PAT[i-1]+PA[i];
                    PAT[i]%=1000000007;   
                 }  
            }
            else
            {
               if(i==0) PAT[i]=0;
               else PAT[i]=PAT[i-1];
            }
        }
        cout<<PAT[len-1]<<endl;
    }
    

    版权声明:本文为博主原创文章,未经博主允许不得转载。

  • 相关阅读:
    判断是否在可视区域
    格式化数字10000,为10,000
    把数组(含有30项分成5组)
    排序
    enzyme 学习一
    golang使用sftp连接服务器远程上传、下载文件
    golang使用ssh远程连接服务器并执行命令
    一文弄懂vlan、三层交换机、网关、DNS、子网掩码、MAC地址的含义
    golang的序列化与反序列化的几种方式
    golang命令行参数解析
  • 原文地址:https://www.cnblogs.com/Tobyuyu/p/4965283.html
Copyright © 2011-2022 走看看