zoukankan      html  css  js  c++  java
  • pat 1083. List Grades (25)

    1083. List Grades (25)

    时间限制
    400 ms
    内存限制
    65536 kB
    代码长度限制
    16000 B
    判题程序
    Standard
    作者
    CHEN, Yue

    Given a list of N student records with name, ID and grade. You are supposed to sort the records with respect to the grade in non-increasing order, and output those student records of which the grades are in a given interval.

    Input Specification:

    Each input file contains one test case. Each case is given in the following format:

    N
    name[1] ID[1] grade[1]
    name[2] ID[2] grade[2]
    ... ...
    name[N] ID[N] grade[N]
    grade1 grade2
    

    where name[i] and ID[i] are strings of no more than 10 characters with no space, grade[i] is an integer in [0, 100], grade1 and grade2 are the boundaries of the grade's interval. It is guaranteed that all the grades are distinct.

    Output Specification:

    For each test case you should output the student records of which the grades are in the given interval [grade1, grade2] and are in non-increasing order. Each student record occupies a line with the student's name and ID, separated by one space. If there is no student's grade in that interval, output "NONE" instead.

    Sample Input 1:
    4
    Tom CS000001 59
    Joe Math990112 89
    Mike CS991301 100
    Mary EE990830 95
    60 100
    
    Sample Output 1:
    Mike CS991301
    Mary EE990830
    Joe Math990112
    
    Sample Input 2:
    2
    Jean AA980920 60
    Ann CS01 80
    90 95
    
    Sample Output 2:
    NONE
    解:结构体存储+按成绩重新排序+控制输出

    代码:

    #include<iostream>
    #include<cstdlib>
    #include<cstdio>
    using namespace std;
    struct stu
    {
        string name;
        string id;
        int grade;
    };
    int main()
    {
        int n;
        while(scanf("%d",&n)==1)
        {
            stu *s=new stu[n+1];
            for(int i=0;i<n;i++)
            {
                cin>>s[i].name>>s[i].id>>s[i].grade;
            }
            int low,upp;
            scanf("%d%d",&low,&upp);
            for(int i=0;i<n;i++)
            {
                int maxi=i;
                for(int j=i+1;j<n;j++)
                {
                    if(s[j].grade>s[maxi].grade)
                        maxi=j;
                }
                stu temp=s[maxi];
                s[maxi]=s[i];
                s[i]=temp;
            }
            if(s[0].grade<low||s[n-1].grade>upp)
            {
                  cout<<"NONE"<<endl;
                  break;
            }
            else
            {
                for(int i=0;i<n;i++)
                {
                    if(s[i].grade>=low&&s[i].grade<=upp)
                    {
                        cout<<s[i].name<<' '<<s[i].id<<endl;
                    }
                 }
            }
        }
    }

    版权声明:本文为博主原创文章,未经博主允许不得转载。

  • 相关阅读:
    Android资源列表
    GTD资源列表[070826更新] [GTD]
    Table显示滚动条
    html语言中的meta元素
    GridView分页的实现
    图解CSS的padding,margin,border属性
    javascript moveTo() 函数
    IE6 中的最大最小寬度和高度 css 高度 控制(兼容版本)
    enableEventValidation
    window.resizeTo()和window.open()
  • 原文地址:https://www.cnblogs.com/Tobyuyu/p/4965291.html
Copyright © 2011-2022 走看看