zoukankan      html  css  js  c++  java
  • HDU

    zhx's contest

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
    Total Submission(s): 448    Accepted Submission(s): 147


    Problem Description
    As one of the most powerful brushes, zhx is required to give his juniors n problems.
    zhx thinks the ith problem's difficulty is i. He wants to arrange these problems in a beautiful way.
    zhx defines a sequence {ai} beautiful if there is an i that matches two rules below:
    1: a1..ai are monotone decreasing or monotone increasing.
    2: ai..an are monotone decreasing or monotone increasing.
    He wants you to tell him that how many permutations of problems are there if the sequence of the problems' difficulty is beautiful.
    zhx knows that the answer may be very huge, and you only need to tell him the answer module p.
     

    Input
    Multiply test cases(less than 1000). Seek EOF as the end of the file.
    For each case, there are two integers n and p separated by a space in a line. (1n,p1018)
     

    Output
    For each test case, output a single line indicating the answer.
     

    Sample Input
    2 233 3 5
     

    Sample Output
    2 1
    Hint
    In the first case, both sequence {1, 2} and {2, 1} are legal. In the second case, sequence {1, 2, 3}, {1, 3, 2}, {2, 1, 3}, {2, 3, 1}, {3, 1, 2}, {3, 2, 1} are legal, so the answer is 6 mod 5 = 1
     

    Source
     






    思路:由题意能够求出答案为(2^n-2)%p


    可是n。p都是LL型的,高速幂的时候会爆LL,所以这里要用到高速乘法,高速乘法事实上和高速幂差点儿相同。就是把乘号改为加号


    注意:当n为1时。要输出1,而当p为1时要输出0。


    AC代码:

    #include <cstdio>
    #include <cstring>
    #include <iostream>
    #include <algorithm>
    #define LL long long 
    using namespace std;
    
    LL n, p;
    
    LL multi(LL a, LL b) {	//高速乘法。事实上和高速幂差点儿相同 
        LL ret = 0;
        while(b) {
            if(b & 1) ret = (ret + a) % p;
            a = (a + a) % p;
            b >>= 1;
        }
        return ret;
    }
    
    LL powmod(LL a, LL b) {	//高速幂 
        LL ret = 1;
        while(b) {
            if(b & 1) ret = multi(ret, a) % p;
            a = multi(a, a) % p;
            b >>= 1;
        }
        return ret;
    }
    
    
    int main() {
    	while(cin >> n >> p) {
    		if(p == 1) {
    			cout << 0 << endl;
    		} else if(n == 1) {
    			cout << 1 << endl;
    		} else {
    			LL ans = powmod(2, n) - 2;
    			if(ans < 0) ans += p;
    			cout << ans << endl;
    		}
    	}
    	return 0;
    }













  • 相关阅读:
    Vue2.0的变化(2)———vue2.0动画的变化、vue-2.0路由的变化
    Vue2.0的变化(1)——vue2.0组件定义/生命周期/循环/自定义键盘/过滤器/组件通信的变化
    YK-iSystem后台管理系统介绍
    通过docker,部署SpringCloud项目
    Quarz框架学习
    安装CentOS6.9虚拟机
    消息中间件JMS(三)
    消息中间件JMS(二)
    消息中间件JMS(一)
    网页静态化技术Freemarker
  • 原文地址:https://www.cnblogs.com/yxwkf/p/5345531.html
Copyright © 2011-2022 走看看