zoukankan      html  css  js  c++  java
  • pat 1036. Boys vs Girls (25)

    1036. Boys vs Girls (25)

    时间限制
    400 ms
    内存限制
    65536 kB
    代码长度限制
    16000 B
    判题程序
    Standard
    作者
    CHEN, Yue

    This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.

    Input Specification:

    Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student's name, gender, ID and grade, separated by a space, where name and ID are strings of no more than 10 characters with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.

    Output Specification:

    For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference gradeF-gradeM. If one such kind of student is missing, output "Absent" in the corresponding line, and output "NA" in the third line instead.

    Sample Input 1:

    3
    Joe M Math990112 89
    Mike M CS991301 100
    Mary F EE990830 95
    
    Sample Output 1:
    Mary EE990830
    Joe Math990112
    6
    
    Sample Input 2:
    1
    Jean M AA980920 60
    
    Sample Output 2:
    Absent
    Jean AA980920
    NA
    
    解:很简单的一道题,定义结构体,每个结构体变量,存储四个值,读取的时候得到男生最低分数对应的下标,女生对应的最高分数的下标,控制输出即可。

    代码:

    <span style="font-family:SimSun;font-size:10px;">#include<iostream>
    #include<cstdlib>
    #include<cstdio>
    using namespace std;
    struct students
    {
        string name;
        string sex;
        string k;
        int grade;
    };
    
    int main()
    {
        int n;
        while(scanf("%d",&n)==1)
        {
            students *stu=new students[n+1];
            int pp=0,grade1=101,qq=0,grade2=-1,g1=0,g2=0;
            for(int i=0;i<n;i++)
            {
                cin>>stu[i].name>>stu[i].sex>>stu[i].k>>stu[i].grade;
                if(stu[i].sex[0]=='M')
                {
                    g1=1;
                    if(stu[i].grade<grade1)
                    {
                        grade1=stu[i].grade;
                        pp=i;
                    }
                }
                if(stu[i].sex[0]=='F')
                {
                    g2=1;
                    if(stu[i].grade>grade2)
                    {
                        grade2=stu[i].grade;
                        qq=i;
                    }
                }
            }
            if(g2==0)
                cout<<"Absent"<<endl;
            else
                cout<<stu[qq].name<<" "<<stu[qq].k<<endl;
            if(g1==0)
                cout<<"Absent"<<endl;
            else
                cout<<stu[pp].name<<" "<<stu[pp].k<<endl;
            if(g1==0||g2==0)
                cout<<"NA"<<endl;
            else
                cout<<stu[qq].grade-stu[pp].grade<<endl;
        }
    }</span>
    


    版权声明:本文为博主原创文章,未经博主允许不得转载。

  • 相关阅读:
    HNOI 2006 BZOJ 1195 最短母串
    BZOJ 3029 守卫者的挑战
    Codeforces 401D Roman and Numbers
    ZJOI2010 数字计数
    BZOJ 3329 Xorequ
    Codeforces 235 C
    SPOJ 8222 Substrings
    BZOJ 1396 识别子串
    (模板)归并排序
    poj3122 Pie (二分)
  • 原文地址:https://www.cnblogs.com/Tobyuyu/p/4965304.html
Copyright © 2011-2022 走看看