zoukankan      html  css  js  c++  java
  • pat 1069. The Black Hole of Numbers (20)

    1069. The Black Hole of Numbers (20)

    时间限制
    100 ms
    内存限制
    65536 kB
    代码长度限制
    16000 B
    判题程序
    Standard
    作者
    CHEN, Yue

    For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174 -- the "black hole" of 4-digit numbers. This number is named Kaprekar Constant.

    For example, start from 6767, we'll get:

    7766 - 6677 = 1089
    9810 - 0189 = 9621
    9621 - 1269 = 8352
    8532 - 2358 = 6174
    7641 - 1467 = 6174
    ... ...

    Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.

    Input Specification:

    Each input file contains one test case which gives a positive integer N in the range (0, 10000).

    Output Specification:

    If all the 4 digits of N are the same, print in one line the equation "N - N = 0000". Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.

    Sample Input 1:
    6767
    
    Sample Output 1:
    7766 - 6677 = 1089
    9810 - 0189 = 9621
    9621 - 1269 = 8352
    8532 - 2358 = 6174
    
    Sample Input 2:
    2222
    
    Sample Output 2:
    2222 - 2222 = 0000
    解:题目有点小坑,我看题目描述以为它应该指定输入四位数,虽然它写的是(0,10000),但是题目也有一句话:Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.总之需要考虑当输入的数值为1位2位3位的情况。

    代码:

    #include<iostream>
    #include<cstdlib>
    #include<cstdio>
    #include<cstring>
    #include<algorithm>
    using namespace std;
    
    int main()
    {
        int cnt=0,n,a[5],temp,num1,num2;
        scanf("%d",&n);
        int hhd=n;
        do
        {
            cnt=0;
            while(hhd)
            {
                a[cnt++]=hhd%10;
                hhd=hhd/10;
            }
            while(cnt<4)
            {
                a[cnt++]=0;
            }
            sort(a,a+cnt);
            if(a[0]==a[1]&&a[1]==a[2]&&a[2]==a[3])
            {
                printf("%d - %d = 0000",n,n);
                break;
            }
            num1=a[3]*1000+a[2]*100+a[1]*10+a[0];
            num2=a[0]*1000+a[1]*100+a[2]*10+a[3];
            cout<<a[3]<<a[2]<<a[1]<<a[0]<<" - "<<a[0]<<a[1]<<a[2]<<a[3]<<" = ";
            hhd=num1-num2;
            if(hhd>=1000&&hhd<=9999)
                cout<<num1-num2<<endl;
            else
            {
                if(hhd>=100&&hhd<=999)
                    cout<<'0'<<hhd<<endl;
                if(hhd>=10&&hhd<=99)
                    cout<<'00'<<hhd<<endl;
                if(hhd>=1&&hhd<=9)
                    cout<<'000'<<hhd<<endl;
            }
        }while(hhd!=6174);
    }

    版权声明:本文为博主原创文章,未经博主允许不得转载。

  • 相关阅读:
    C# 杂项
    C# 数组
    我的博客第一天
    Java使用多线程异步执行批量更新操作
    Python爬取百度图片
    以友盟+U-Push为例,深度解读消息推送的筛选架构解决方案应用与实践
    python自动化办公之爬取HTML图片写入PPT实战
    理解Python闭包,这应该是最好的例子
    爬取b站《守护解放西》弹幕
    爬取b站《守护解放西》弹幕
  • 原文地址:https://www.cnblogs.com/Tobyuyu/p/4965357.html
Copyright © 2011-2022 走看看