zoukankan      html  css  js  c++  java
  • Rock,Paper,Scissors 水NOJ 1090

    Rock, Paper, Scissors

    时间限制(普通/Java) : 1500 MS/ 10000 MS          运行内存限制 : 65536 KByte
    总提交 : 230            测试通过 : 107 

    题目描述

    Rock, Paper, Scissors is a classic hand game for two people. Each participant holds out either a fist (rock), open hand (paper), or two-finger V (scissors). If both players show the same gesture, they try again. They continue until there are two different gestures. The winner is then determined according to the table below:
     
    Rock beats Scissors    
    Paper beats Rock    
    Scissors beats Paper  
    Your task is to take a list of symbols representing the gestures of two players and determine how many games each player wins.
    In the following example:

    Turn     : 1 2 3 4 5
    Player 1 : R R S R S
    Player 2 : S R S P S
    Player 1 wins at Turn 1 (Rock beats Scissors), Player 2 wins at Turn 4 (Paper beats Rock), and all the other turns are ties.



    输入

    The input contains between 1 and 20 pairs of lines, the first for Player 1 and the second for Player 2. Both player lines contain the same number of symbols from the set {'R', 'P', 'S'}.  The number of symbols per line is between 1 and 75, inclusive.  A pair of lines each containing the single character 'E' signifies the end of the input.

    输出

    For each pair of input lines, output a pair of output lines as shown in the sample output, indicating the number of games won by each player.

    样例输入

    RRSRS
    SRSPS
    PPP
    SSS
    SPPSRR
    PSPSRS
    E
    E

    样例输出

    P1: 1
    P2: 1
    P1: 0
    P2: 3
    P1: 2
    P2: 1

    水题就不废话了~

    实现代码:

    <span style="font-size:12px;">#include<iostream>
    #include<cstdlib>
    #include<cstdio>
    #include<cstring>
    using namespace std;
    char a[76],b[76];
    int main()
    {
        while(scanf("%s%s",&a,&b)&&!(a[0]=='E'&&b[0]=='E'))
        {
            int len=strlen(a);
            int aa=0,bb=0;
            for(int i=0;i<len;i++)
            {
                if(a[i]=='R')
                {
                    if(b[i]=='S')
                    {
                        aa++;
                    }
                    if(b[i]=='P')
                    {
                        bb++;
                    }
                }
                else if(a[i]=='P')
                {
                    if(b[i]=='R')
                    {
                        aa++;
                    }
                    if(b[i]=='S')
                    {
                        bb++;
                    }
                }
                else if(a[i]=='S')
                {
                    if(b[i]=='P')
                    {
                        aa++;
                    }
                    if(b[i]=='R')
                    {
                        bb++;
                    }
                }
            }
            printf("P1: %d
    P2: %d
    ",aa,bb);
        }
    }</span>

    Rock, Paper, Scissors

    时间限制(普通/Java) : 1500 MS/ 10000 MS          运行内存限制 : 65536 KByte
    总提交 : 230            测试通过 : 107 

    题目描述

    Rock, Paper, Scissors is a classic hand game for two people. Each participant holds out either a fist (rock), open hand (paper), or two-finger V (scissors). If both players show the same gesture, they try again. They continue until there are two different gestures. The winner is then determined according to the table below:
     
    Rock beats Scissors    
    Paper beats Rock    
    Scissors beats Paper  
    Your task is to take a list of symbols representing the gestures of two players and determine how many games each player wins.
    In the following example:

    Turn     : 1 2 3 4 5
    Player 1 : R R S R S
    Player 2 : S R S P S
    Player 1 wins at Turn 1 (Rock beats Scissors), Player 2 wins at Turn 4 (Paper beats Rock), and all the other turns are ties.



    输入

    The input contains between 1 and 20 pairs of lines, the first for Player 1 and the second for Player 2. Both player lines contain the same number of symbols from the set {'R', 'P', 'S'}.  The number of symbols per line is between 1 and 75, inclusive.  A pair of lines each containing the single character 'E' signifies the end of the input.

    输出

    For each pair of input lines, output a pair of output lines as shown in the sample output, indicating the number of games won by each player.

    样例输入

    RRSRS
    SRSPS
    PPP
    SSS
    SPPSRR
    PSPSRS
    E
    E

    样例输出

    P1: 1
    P2: 1
    P1: 0
    P2: 3
    P1: 2
    P2: 1

    题目来源

    ACM Mid-Central Regional 2009

    版权声明:本文为博主原创文章,未经博主允许不得转载。

  • 相关阅读:
    Jms的MessageListener中的Jms事务
    Maven依赖排除 禁止依赖传递 取消依赖的方法
    数据库事务隔离级别-- 脏读、幻读、不可重复读(清晰解释)
    【JMS】JMS之ActiveMQ的使用
    servlet3.0 新特性——异步处理
    pyCharm远程调试
    pycharm激活方法(包括永久激活)
    UnicodeDecodeError: 'utf-8' codec can't decode byte 0xa1 in position 3: invalid start byte错误解决办法
    Python数据分析Pandas的编程经验总结
    java版的状态机实现
  • 原文地址:https://www.cnblogs.com/Tobyuyu/p/4965498.html
Copyright © 2011-2022 走看看