Description
编写用来交换两个数的函数,使得“Append Code”中的main()函数能正确运行。
-----------------------------------------------------------------------------
用C实现三个函数int_swap()、dbl_swap()、SWAP(),其中SWAP()是个带参宏。
用C++实现两个函数,都以swap()命名。
以上函数的调用格式见“Append Code”。这里不给出函数原型,它们的参数请通过main()函数自行确定。
Input
输入为4行,每行2个数。
Output
输出为4行,每行2个数。每行输出的两数为每行输入的逆序。
Sample Input
12 57
9 -3
-12 4
3 5
Sample Output
57 12
-3 9
4 -12
5 3
HINT
“Append Code”中用到的头文件、全局变量或宏的定义应自行补充。
Append Code
#include<iostream>
using
namespace
std;
void
swap(
int
*a,
int
*b)
{
int
t;
t=*a;
*a=*b;
*b=t;
}
void
swap(
int
&a,
int
&b)
{
int
t;
t=a;
a=b;
b=t;
}
void
swap(
double
*a,
double
*b)
{
double
t;
t=*a;
*a=*b;
*b=t;
}
void
swap(
double
&a,
double
&b)
{
double
t;
t=a;
a=b;
b=t;
}
int
main()
{
int
x1, y1;
cin>>x1>>y1;
swap(&x1, &y1);
cout<<x1<<
" "
<<y1<<endl;
cin>>x1>>y1;
swap(x1, y1);
cout<<x1<<
" "
<<y1<<endl;
double
x2, y2;
cin>>x2>>y2;
swap(&x2, &y2);
cout<<x2<<
" "
<<y2<<endl;
cin>>x2>>y2;
swap(x2, y2);
cout<<x2<<
" "
<<y2<<endl;
}