zoukankan      html  css  js  c++  java
  • Problem H: 平面上的点和线——Point类、Line类 (IV)

    Description

    在数学上,平面直角坐标系上的点用X轴和Y轴上的两个坐标值唯一确定,两点确定一条线段。现在我们封装一个“Point类”和“Line类”来实现平面上的点的操作。
    根据“append.cc”,完成Point类和Line类的构造方法和show()方法,输出各Line对象和Point对象的构造和析构次序。
    接口描述:
    Point::show()方法:按格式输出Point对象。
    Line::show()方法:按格式输出Line对象。

    Input

    输入的第一行为N,表示后面有N行测试样例。

    每行为两组坐标“x,y”,分别表示线段起点和终点的x坐标和y坐标,两组坐标间用一个空格分开,x和y的值都在double数据范围内。

    Output

    输出为多行,每行为一条线段,起点坐标在前终点坐标在后,每个点的X坐标在前,Y坐标在后,Y坐标前面多输出一个空格,用括号包裹起来。输出格式见sample。
    C语言的输入输出被禁用。

    Sample Input

    4
    0,0 1,1
    1,1 2,3
    2,3 4,5
    0,1 1,0

    Sample Output

    Point : (1, -2) is created.
    Point : (2, -1) is created.
    Point : (0, 0) is created.
    Point : (0, 0)
    Point : (0, 0) is created.
    Point : (0, 0) is created.
    Line : (0, 0) to (0, 0) is created.
    Point : (0, 0) is created.
    Point : (0, 0) is created.
    Line : (0, 0) to (0, 0) is created.
    Point : (0, 0) is created.
    Point : (0, 0) is created.
    Line : (0, 0) to (0, 0) is created.
    Point : (0, 0) is created.
    Point : (0, 0) is created.
    Line : (0, 0) to (0, 0) is created.
    =========================
    Line : (0, 0) to (1, 1)
    =========================
    Line : (1, 1) to (2, 3)
    =========================
    Line : (2, 3) to (4, 5)
    =========================
    Line : (0, 1) to (1, 0)
    =========================
    Point : (1, -2) is copied.
    Point : (2, -1) is copied.
    Line : (1, -2) to (2, -1) is created.
    Point : (1, -2) is copied.
    Point : (0, 0) is copied.
    Line : (1, -2) to (0, 0) is created.
    Point : (2, -1) is copied.
    Point : (0, 0) is copied.
    Line : (2, -1) to (0, 0) is created.
    Point : (0, 0) is copied.
    Point : (2, -1) is copied.
    Line : (0, 0) to (2, -1) is created.
    Line : (1, -2) to (2, -1)
    Line : (1, -2) to (0, 0)
    Line : (2, -1) to (0, 0)
    Line : (0, 0) to (2, -1)
    Line : (0, 0) to (2, -1) is erased.
    Point : (2, -1) is erased.
    Point : (0, 0) is erased.
    Line : (2, -1) to (0, 0) is erased.
    Point : (0, 0) is erased.
    Point : (2, -1) is erased.
    Line : (1, -2) to (0, 0) is erased.
    Point : (0, 0) is erased.
    Point : (1, -2) is erased.
    Line : (1, -2) to (2, -1) is erased.
    Point : (2, -1) is erased.
    Point : (1, -2) is erased.
    Line : (0, 1) to (1, 0) is erased.
    Point : (1, 0) is erased.
    Point : (0, 1) is erased.
    Line : (2, 3) to (4, 5) is erased.
    Point : (4, 5) is erased.
    Point : (2, 3) is erased.
    Line : (1, 1) to (2, 3) is erased.
    Point : (2, 3) is erased.
    Point : (1, 1) is erased.
    Line : (0, 0) to (1, 1) is erased.
    Point : (1, 1) is erased.
    Point : (0, 0) is erased.
    Point : (0, 0) is erased.
    Point : (2, -1) is erased.
    Point : (1, -2) is erased.

    HINT

    Append Code

    #include<iostream>
    using namespace std;
    class Point
    {
    private:
        double x,y;
    public:
        Point(double a=0,double b=0):x(a),y(b){cout<<"Point : ("<<x<<", "<<y<<") is created."<<endl;}
        ~Point(){cout<<"Point : ("<<x<<", "<<y<<") is erased."<<endl;}
        Point(const Point &q){x=q.x;y=q.y;cout<<"Point : ("<<x<<", "<<y<<") is copied."<<endl;}
        double getX(){return x;}
        double getY(){return y;}
        void setX(double a){x=a;}
         void setY(double b){y=b;}
        void show(){cout<<"Point : ("<<x<<", "<<y<<")"<<endl;}
    };
    class Line
    {
    private:
        Point xx,yy;
    public:
        Line():xx(0,0),yy(0,0){cout<<"Line : ("<<xx.getX()<<", "<<xx.getY()<<") to ("<<yy.getX()<<", "<<yy.getY()<<") is created."<<endl;}
        Line(double a,double b,double c,double d):xx(a,b),yy(c,d){cout<<"Line : ("<<xx.getX()<<", "<<xx.getY()<<") to ("<<yy.getX()<<", "<<yy.getY()<<") is created."<<endl;}
         Line(Point &a,Point &b):xx(a),yy(b){cout<<"Line : ("<<xx.getX()<<", "<<xx.getY()<<") to ("<<yy.getX()<<", "<<yy.getY()<<") is created."<<endl;}
        void show(){cout<<"Line : ("<<xx.getX()<<", "<<xx.getY()<<") to ("<<yy.getX()<<", "<<yy.getY()<<")"<<endl;}
        ~Line(){cout<<"Line : ("<<xx.getX()<<", "<<xx.getY()<<") to ("<<yy.getX()<<", "<<yy.getY()<<") is erased."<<endl;}
        void SetLine(double a,double b,double c,double d){xx.setX(a),xx.setY(b),yy.setX(c),yy.setY(d);}
    };
    int main()
    {
        char c;
        int num, i;
        double x1, x2, y1, y2;
        Point p(1, -2), q(2, -1), t;
        t.show();
        std::cin>>num;
        Line line[num];
        for(i = 0; i < num; i++)
        {
            std::cout<<"========================= ";
            std::cin>>x1>>c>>y1>>x2>>c>>y2;
            line[i].SetLine(x1, y1, x2, y2);
            line[i].show();
        }
        std::cout<<"========================= ";
        Line l1(p, q), l2(p, t), l3(q, t), l4(t, q);
        l1.show();
        l2.show();
        l3.show();
        l4.show();
    }
  • 相关阅读:
    将一个表的结果集插入到另一个表中
    sqlite 函数大全
    sqlite数据库实现字符串查找的方法(instr,substring,charindex替代方案)
    sqlite 字符串 转 整型 cast 函数 (强制类型转换 )
    sqlite 截取字符串函数substr
    sql 注释 语法
    实现iOS长时间后台的两种方法:Audiosession和VOIP
    iOS越狱知多少?
    从一个开发者的角度看越狱
    iPhone系统常用文件夹位置
  • 原文地址:https://www.cnblogs.com/TogetherLaugh/p/6544771.html
Copyright © 2011-2022 走看看