zoukankan      html  css  js  c++  java
  • 滑雪

    滑雪
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 97321   Accepted: 36903

    Description

    Michael喜欢滑雪百这并不奇怪, 因为滑雪的确很刺激。可是为了获得速度,滑的区域必须向下倾斜,而且当你滑到坡底,你不得不再次走上坡或者等待升降机来载你。Michael想知道载一个区域中最长底滑坡。区域由一个二维数组给出。数组的每个数字代表点的高度。下面是一个例子 
     1  2  3  4 5
    
    16 17 18 19 6
    15 24 25 20 7
    14 23 22 21 8
    13 12 11 10 9

    一个人可以从某个点滑向上下左右相邻四个点之一,当且仅当高度减小。在上面的例子中,一条可滑行的滑坡为24-17-16-1。当然25-24-23-...-3-2-1更长。事实上,这是最长的一条。

    Input

    输入的第一行表示区域的行数R和列数C(1 <= R,C <= 100)。下面是R行,每行有C个整数,代表高度h,0<=h<=10000。

    Output

    输出最长区域的长度。

    Sample Input

    5 5
    1 2 3 4 5
    16 17 18 19 6
    15 24 25 20 7
    14 23 22 21 8
    13 12 11 10 9
    

    Sample Output

    25



    将一个点的上下左右的点计算出来。
    #include<iostream>
    using namespace std;
    int map[100][100],ans[100][100],m,n;
    int next[4][2]={{-1,0},{0,1},{1,0},{0,-1}};//上下左右的移动
    int dp(int i,int j)
    {
        if(ans[i][j]!=0)
            return ans[i][j];
        int mx=0,s;
        for(int k=0;k<4;k++)//四种方向
        {
            int t1=i+next[k][0],t2=j+next[k][1];//移动方向
            if(t1>=0&&t1<m&&t2>=0&&t2<n&&map[t1][t2]<map[i][j])//判断出界,是否能走
            {
                s=dp(t1,t2);
                if(s>mx)
                    mx=s;//更新最大
            }
        }
        ans[i][j]=mx+1;//自己的点
        return ans[i][j];
    }
    int main()
    {
        int i,j,maxans=0;
        cin>>m>>n;
        for(i=0;i<m;i++)
        {
            for(j=0;j<n;j++)
            {
                scanf("%d",&map[i][j]);
            }
        }
        for(i=0;i<m;i++)
        {
            for(j=0;j<n;j++)
            {
                ans[i][j]=dp(i,j);//每个点的值
                if(ans[i][j]>maxans)
                    maxans=ans[i][j];//最大
            }
        }
        cout<<maxans;
        //system("pause");
        return 0;
    }
    

      

    蒟蒻总是更懂你✿✿ヽ(°▽°)ノ✿
  • 相关阅读:
    Unity The Method Signature Matching Rule
    Unity The Property Matching Rule
    Unity The Type Matching Rule
    Unity The Custom Attribute Matching Rule
    Unity The Member Name Matching Rule
    Unity No Policies
    Unity The Return Type Matching Rule
    Unity The Parameter Type Matching Rule
    Unity The Namespace Matching Rule
    关于TSQL递归查询的(转)
  • 原文地址:https://www.cnblogs.com/WWHHTT/p/6922601.html
Copyright © 2011-2022 走看看