zoukankan      html  css  js  c++  java
  • 科赫曲线

    题目链接: http://judge.u-aizu.ac.jp/onlinejudge/description.jsp?id=ALDS1_5_C

    Write a program which reads an integer n and draws a Koch curve based on recursive calles of depth n.

    The Koch curve is well known as a kind of fractals.

    You can draw a Koch curve in the following algorithm:

    • Divide a given segment (p1, p2) into three equal segments.
    • Replace the middle segment by the two sides of an equilateral triangle (s, u, t) of the same length as the segment.
    • Repeat this procedure recursively for new segments (p1, s), (s, u), (u, t), (t, p2).

    You should start (0, 0), (100, 0) as the first segment.

    Input

    An integer n is given.

    Output

    Print each point (x, y) of the Koch curve. Print a point in a line. You should start the point(0, 0), which is the endpoint of the first segment and end with the point (100, 0), the other endpoint so that you can draw the Koch curve as an unbroken line. Each solution should be given as a decimal with an arbitrary number of fractional digits, and with an absolute error of at most 10-4.

    Constraints
    • 0 ≤ n ≤ 6
    Sample Input 1
    1
    
    Sample Output 1
    0.00000000 0.00000000
    33.33333333 0.00000000
    50.00000000 28.86751346
    66.66666667 0.00000000
    100.00000000 0.00000000
    
    Sample Input 2
    2
    
    Sample Output 2
    0.00000000 0.00000000
    11.11111111 0.00000000
    16.66666667 9.62250449
    22.22222222 0.00000000
    33.33333333 0.00000000
    38.88888889 9.62250449
    33.33333333 19.24500897
    44.44444444 19.24500897
    50.00000000 28.86751346
    55.55555556 19.24500897
    66.66666667 19.24500897
    61.11111111 9.62250449
    66.66666667 0.00000000
    77.77777778 0.00000000
    83.33333333 9.62250449
    88.88888889 0.00000000
    100.00000000 0.00000000
    

    这道题是使用递归做的。从题目的描述我们可以得知科赫曲线的作画流程,首先将线段三等分,然后以中间的两个等分点作为顶点画一个等边三角形,最后重复在每条线段上进行以上步骤。从上面的说明也可以知道这个过程是不断递归的。这道题具体的做法分为以下几步:

    1. 线段的两个端点为p1, p2,计算三等分点的坐标s,t,计算u的坐标
    2. 对线段p1s递归调用函数,输出s的坐标
    3. 对线段su递归调用函数,输出u的坐标
    4. 对线段ut递归调用函数,输出t的坐标
    5. 对线段tp2递归调用函数

    p1p2的坐标在主函数中已经输出了,即两个端点的坐标在上一层递归时已经输出。坐标的求法可以自行搜索,根据公式写出程序即可。

    参考代码:

    import java.util.Scanner;
    
    class  Point{
        double x;
        double y;
    
        Point(){}
    
        Point(double x, double y){
            this.x = x;
            this.y = y;
        }
    }
    
    public class KochCurve {
    
        public static void main(String[] args) {
            Scanner sc = new Scanner(System.in);
            int n = sc.nextInt();
    
            Point p1 = new Point(0, 0);
            Point p2 = new Point(100, 0);
    
            System.out.println(String.format("%.8f", p1.x) + " " + String.format("%.8f", p1.y));
            koch(n, p1, p2);
            System.out.println(String.format("%.8f", p2.x) + " " + String.format("%.8f", p2.y));
        }
    
        private static void koch(int n, Point p1, Point p2) {
    
            if (n == 0){
                return;
            }
    
            // 将角度转变为弧度
            double th = Math.PI * 60.0 / 180.0;
    
            Point s = new Point();
            Point t = new Point();
            Point u = new Point();
    
            s.x = (2*p1.x + p2.x) / 3;
            s.y = (2*p1.y + p2.y) / 3;
    
            t.x = (p1.x + 2*p2.x) / 3;
            t.y = (p1.y + 2*p2.y) / 3;
    
            u.x = (t.x - s.x) * Math.cos(th) - (t.y - s.y) * Math.sin(th) + s.x;
            u.y = (t.x - s.x) * Math.sin(th) + (t.y - s.y) * Math.cos(th) + s.y;
    
            koch(n-1, p1, s);
            System.out.println(String.format("%.8f", s.x) + " " + String.format("%.8f", s.y));
            koch(n-1, s, u);
            System.out.println(String.format("%.8f", u.x) + " " + String.format("%.8f", u.y));
            koch(n-1, u, t);
            System.out.println(String.format("%.8f", t.x) + " " + String.format("%.8f", t.y));
            koch(n-1, t, p2);
        }
    }
    
    

    参考文献:《挑战程序设计竞赛-算法和数据结构》

  • 相关阅读:
    HTML总结
    js五角星评分特效
    正则表达式
    C#文件路径的写法
    vs2010发布网站
    INI文件阅读器
    .net读取xml文件中文乱码问题解决办法
    js利用定时器动态改变层大小
    c#中ref和out的用法
    分享一篇关于C#对文件操作的日志,方法很全
  • 原文地址:https://www.cnblogs.com/WanJiaJia/p/8036456.html
Copyright © 2011-2022 走看看