zoukankan      html  css  js  c++  java
  • (Set) 人见人爱A-B HDU2034

    人见人爱A-B

    链接:http://acm.hdu.edu.cn/showproblem.php?pid=2034

    JAVA代码借鉴链接:https://blog.csdn.net/superbeauty/article/details/47065691

    Problem Description
    参加过上个月月赛的同学一定还记得其中的一个最简单的题目,就是{A}+{B},那个题目求的是两个集合的并集,今天我们这个A-B求的是两个集合的差,就是做集合的减法运算。(当然,大家都知道集合的定义,就是同一个集合中不会有两个相同的元素,这里还是提醒大家一下)

    呵呵,很简单吧?
     
    Input
    每组输入数据占1行,每行数据的开始是2个整数n(0<=n<=100)和m(0<=m<=100),分别表示集合A和集合B的元素个数,然后紧跟着n+m个元素,前面n个元素属于集合A,其余的属于集合B. 每个元素为不超出int范围的整数,元素之间有一个空格隔开.
    如果n=0并且m=0表示输入的结束,不做处理。
     
    Output
    针对每组数据输出一行数据,表示A-B的结果,如果结果为空集合,则输出“NULL”,否则从小到大输出结果,为了简化问题,每个元素后面跟一个空格.
     
    Sample Input
    3 3 1 2 3 1 4 7
    3 7 2 5 8 2 3 4 5 6 7 8
    0 0
     
    Sample Output
    2 3
    NULL
     
    注:
      这个题是可以用JAVA的Set类,注意输出格式,要审题,要检验结果是否符合要求。
     
    JAVA代码:
    import java.math.BigDecimal;
    import java.util.Scanner;
    import java.util.Set;
    import java.util.TreeSet;
    
    import javax.swing.plaf.basic.BasicArrowButton;
    
    public class Main {
    
        public static void main(String[] args) {
            Scanner inScanner = new Scanner(System.in);
            while(inScanner.hasNext()) {
                int a = inScanner.nextInt();
                int b = inScanner.nextInt();
                if(a==0 && b==0) {
                    break;
                }
                else {
                    Set<Integer> set = new TreeSet<>();   // 要掌握。
                    for(int i = 0;i<a;i++) {
                        int x = inScanner.nextInt();
                        set.add(x);
                    }
                    for(int i = 0;i<b;i++) {
                        int x = inScanner.nextInt();
                        if(set.contains(x)) {
                            set.remove(x);
                        }
                    }
                    if(set.isEmpty()) {
                        System.out.print("NULL");   //注意格式。
                    }
                    else {
                        for(Integer i:set) {
                            System.out.print(i + " "); //注意格式。
                        }
                    }
                }
                System.out.println();
            }
        }
    
    }
    也可以用C++代码:(想的有点复杂了)
    思路:

    这个是求A中没有B的数。此处可以用set的,只要将A中的数建立集合,然后,对B中的数进行遍历就够了。此时还会用到find,erase等函数,注意运用。此外,find函数,在set中,是在[first,last)中查询符合条件的数,如果未找到,则返回last的所在的位置。

    #include <iostream>
    #include<set>
    using namespace std;
    int main()
    {
        set<int> m;
        int a,b,c;
        while(cin>>a>>b)
        {
            m.clear();
            if(a==0&&b==0)
                break;
            for(int i=0;i<a;i++)
            {
                cin>>c;
                m.insert(c);
            }
            for(int i=0;i<b;i++)
            {
                cin>>c;
                if(m.find(c)!=m.end())
                    m.erase(c);
            }
            if(m.size()==0)
                cout<<"NULL"<<endl;
            else
            {
                set<int>::iterator it=m.begin();
                for(;it!=m.end();it++)
                    cout<<*it<<" ";
                cout<<endl;
            }
        }
        return 0;
    } 
  • 相关阅读:
    网站加载速度优化的14个技巧
    op+3g
    Xmind 快捷键
    Resty 一款极简的restful轻量级的web框架
    linux磁盘限额配置:quota命令
    常用报表工具
    http://mirror2.openwrt.org/sources/
    op挂载摄像头
    supported platform
    OpenWrt Kernel Module Creation Howto
  • 原文地址:https://www.cnblogs.com/Weixu-Liu/p/9649257.html
Copyright © 2011-2022 走看看