zoukankan      html  css  js  c++  java
  • (全排列)Ignatius and the Princess II -- HDU -- 1027

    链接:

    http://acm.hdu.edu.cn/showproblem.php?pid=1027

    Ignatius and the Princess II

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 5822    Accepted Submission(s): 3433


    Problem Description
    Now our hero finds the door to the BEelzebub feng5166. He opens the door and finds feng5166 is about to kill our pretty Princess. But now the BEelzebub has to beat our hero first. feng5166 says, "I have three question for you, if you can work them out, I will release the Princess, or you will be my dinner, too." Ignatius says confidently, "OK, at last, I will save the Princess."

    "Now I will show you the first problem." feng5166 says, "Given a sequence of number 1 to N, we define that 1,2,3...N-1,N is the smallest sequence among all the sequence which can be composed with number 1 to N(each number can be and should be use only once in this problem). So it's easy to see the second smallest sequence is 1,2,3...N,N-1. Now I will give you two numbers, N and M. You should tell me the Mth smallest sequence which is composed with number 1 to N. It's easy, isn't is? Hahahahaha......"
    Can you help Ignatius to solve this problem?
     
    Input
    The input contains several test cases. Each test case consists of two numbers, N and M(1<=N<=1000, 1<=M<=10000). You may assume that there is always a sequence satisfied the BEelzebub's demand. The input is terminated by the end of file.
     
    Output
    For each test case, you only have to output the sequence satisfied the BEelzebub's demand. When output a sequence, you should print a space between two numbers, but do not output any spaces after the last number.
     
    Sample Input
    6 4
    11 8
     
    Sample Output
    1 2 3 5 6 4
    1 2 3 4 5 6 7 9 8 11 10

    代码:

    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <cstdlib>
    #include <algorithm>
    #include <queue>
    
    using namespace std;
    
    #define N 1100
    
    
    int main()
    {
        int n, m;
    
        while(scanf("%d%d", &n, &m)!=EOF)
        {
            int a[N];
    
            for(int i=1; i<=n; i++)
                a[i] = i;
    
            m--;
    
            while(m--)
            {
                next_permutation(a+1, a+n+1); /// next_permutation(数组名+起始位置,数组名+长度)
            }
    
            for(int i=1; i<=n; i++)
                printf("%d%c", a[i], i==n?'
    ':' ');
    
        }
        return 0;
    }
    勿忘初心
  • 相关阅读:
    docker基础命令
    Dubbo添加Filter过滤器
    Jvm FullGC 如何排查?
    ElastaticSearch----es聚合,并获取query的排序结果
    java8 StringJoiner拼接字符串
    ElastaticSearch--- es多字段聚合
    java使用Mysql批量更新(先查询,再插入或更新)
    Mybatis批量插入,批量更新
    谷粒商城学习——P51商品服务-API-三级分类-删除-删除效果细化
    谷粒商城学习——P50商品服务-API-三级分类-删除-逻辑删除
  • 原文地址:https://www.cnblogs.com/YY56/p/4776926.html
Copyright © 2011-2022 走看看