zoukankan      html  css  js  c++  java
  • POJ 2259-Team Queue[队列]

    Description

    Queues and Priority Queues are data structures which are known to most computer scientists. The Team Queue, however, is not so well known, though it occurs often in everyday life. At lunch time the queue in front of the Mensa is a team queue, for example.

    In a team queue each element belongs to a team. If an element enters the queue, it first searches the queue from head to tail to check if some of its teammates (elements of the same team) are already in the queue. If yes, it enters the queue right behind them. If not, it enters the queue at the tail and becomes the new last element (bad luck). Dequeuing is done like in normal queues: elements are processed from head to tail in the order they appear in the team queue.

    Your task is to write a program that simulates such a team queue.
    Input

    The input will contain one or more test cases. Each test case begins with the number of teams t (1<=t<=1000). Then t team descriptions follow, each one consisting of the number of elements belonging to the team and the elements themselves. Elements are integers in the range 0 - 999999. A team may consist of up to 1000 elements.
    Finally, a list of commands follows. There are three different kinds of commands:
    ENQUEUE x - enter element x into the team queue
    DEQUEUE - process the first element and remove it from the queue
    STOP - end of test case

    The input will be terminated by a value of 0 for t.
    Warning: A test case may contain up to 200000 (two hundred thousand) commands, so the implementation of the team queue should be efficient: both enqueing and dequeuing of an element should only take constant time.
    Output

    For each test case, first print a line saying “Scenario #k”, where k is the number of the test case. Then, for each DEQUEUE command, print the element which is dequeued on a single line. Print a blank line after each test case, even after the last one.
    Sample Input

    2
    3 101 102 103
    3 201 202 203
    ENQUEUE 101
    ENQUEUE 201
    ENQUEUE 102
    ENQUEUE 202
    ENQUEUE 103
    ENQUEUE 203
    DEQUEUE
    DEQUEUE
    DEQUEUE
    DEQUEUE
    DEQUEUE
    DEQUEUE
    STOP
    2
    5 259001 259002 259003 259004 259005
    6 260001 260002 260003 260004 260005 260006
    ENQUEUE 259001
    ENQUEUE 260001
    ENQUEUE 259002
    ENQUEUE 259003
    ENQUEUE 259004
    ENQUEUE 259005
    DEQUEUE
    DEQUEUE
    ENQUEUE 260002
    ENQUEUE 260003
    DEQUEUE
    DEQUEUE
    DEQUEUE
    DEQUEUE
    STOP
    0
    Sample Output

    Scenario #1
    101
    102
    103
    201
    202
    203

    Scenario #2
    259001
    259002
    259003
    259004
    259005
    260001
    Source

    Ulm Local 1998
    .
    .
    .
    .
    .

    程序:
    #include <iostream>
    #include <queue>
    using namespace std;
    int team[999999];
    int main()
    {
        int t,k=1,x;
        while (cin>>t)
        {
            if (t==0) break;
            cout<<"Scenario #"<<k<<endl;
            k++;
            for (int i=0;i<t;i++)
            {
                int n;
                cin>>n;
                for (int j=0;j<n;j++)
                {
                    cin>>x;
                    team[x]=i;
                }
            }
            queue <int> q,q2[1001];
            while (1!=0)
            {
                int x;
                char ch[8];
                cin>>ch;
                if (ch[0]=='S') break; else 
                if (ch[0]=='E')
                {
                    cin>>x;
                    int t=team[x];
                    if (q2[t].empty()) q.push(t);
                    q2[t].push(x);
                } else 
                if (ch[0]=='D')
                {
                    int t=q.front();
                    cout<<q2[t].front()<<endl;
                    q2[t].pop();
                    if (q2[t].empty()) q.pop(); 
                }
            }
            cout<<endl;
        }
        return 0;
    }
  • 相关阅读:
    STM32低功耗模式与烟雾报警器触发信号电路设计
    cocos2d-x的环境的搭建
    window8.1中用户的管理员权限的提升方法
    cmd中目录的变更
    js的传值,table中tr的遍历,js中动态创建数组
    究竟什么是游戏引擎?
    大型网站架构学习心德
    关于listView 中的聚焦问题
    android6.0 适配的问题——activity销毁的问题
    文件发送成功率低的问题(2)
  • 原文地址:https://www.cnblogs.com/YYC-0304/p/9499895.html
Copyright © 2011-2022 走看看