zoukankan      html  css  js  c++  java
  • POJ 2253 Frogger (Floyd)

                                  Frogger
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions:57696   Accepted: 18104

    Description

    Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping. 
    Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps. 
    To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence. 
    The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones. 

    You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone. 

    Input

    The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

    Output

    For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

    Sample Input

    2
    0 0
    3 4
    
    3
    17 4
    19 4
    18 5
    
    0
    

    Sample Output

    Scenario #1
    Frog Distance = 5.000
    
    Scenario #2
    Frog Distance = 1.414

    思路
    有i, j, k 三个点,如果i到j的距离比i到k,k到j的距离都大,那就先跳到k,再跳到j,否则,就直接跳到j。
    由此我们可知,这个更新的方式,与最短路略有不同。

    代码
    #include<iostream>
    #include<cmath>
    #include<cstdio>
    #include<cstring>
    #include<queue>
    using namespace std;
    double d[508][508];
    int a[508][2],n;
    int main()
    {
        int T;
        T=0;
        while(cin>>n&&n){
            T++;
            memset(d,0,sizeof(d));
            for(int i=1;i<=n;i++){
                cin>>a[i][0]>>a[i][1];
            }
            for(int i=1;i<=n;i++){
                for(int k=i+1;k<=n;k++){
                    d[i][k]=d[k][i]=sqrt((double)((a[i][0]-a[k][0])*(a[i][0]-a[k][0])+(a[i][1]-a[k][1])*(a[i][1]-a[k][1])));
                }
            }
            for(int k=1;k<=n;k++){
                for(int j=1;j<=n;j++){
                    for(int i=1;i<=n;i++){
                        if(d[i][j]>d[i][k]&&d[i][j]>d[k][j]){
                            d[j][i]=d[i][j]=max(d[i][k],d[k][j]);
                        }
                    }
                }
            }
            printf("Scenario #%d
    Frog Distance = %.3f
    
    ",T,d[1][2]);
        }
    }
     
  • 相关阅读:
    转载一篇 Linux 命令总结
    Linux 常用命令学习
    frp 使用
    Anaconda使用记录
    Linux 学习
    lnmp下django学习
    lnmp安装学习
    学习DHT内容
    pyqt5配置
    MyBatisPlus 常用知识点总结
  • 原文地址:https://www.cnblogs.com/ZGQblogs/p/9382121.html
Copyright © 2011-2022 走看看