zoukankan      html  css  js  c++  java
  • 数据结构练习 01-复杂度2. Maximum Subsequence Sum (25)

    Given a sequence of K integers { N1, N2, ..., NK }. A continuous subsequence is defined to be { Ni, Ni+1, ..., Nj } where 1 <= i <= j <= K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

    Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

    Input Specification:

    Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (<= 10000). The second line contains K numbers, separated by a space.

    Output Specification:

    For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

    Sample Input:

    10
    -10 1 2 3 4 -5 -23 3 7 -21
    

    Sample Output:

    10 1 4
     
    #include<iostream>
    using namespace std;
    int MaxsubseqSum2(int a[],int k,int *first,int *last){
        int ThisSum=0,MaxSum=0;
        int c=0,d=0,e=0;
        for(int i=0;i<k;i++){
            ThisSum+=a[i];
            if(ThisSum>MaxSum){
                MaxSum=ThisSum;
                *last=a[i];
                d=i;
            }else if(ThisSum<0){
                ThisSum=0;
                e++;
            }else if(ThisSum==MaxSum &&MaxSum==0){
                MaxSum=ThisSum;
                *last=a[i];
                d=i;
            }
            
        }
        if(e==0){
            *first=a[0];
        }
        ThisSum=0;
        for(int i=0;i<d;i++){
            ThisSum+=a[i];
            if(ThisSum<0){
                ThisSum=0;
                *first=a[i+1];
            }
            
        }
        if(MaxSum==0 && a[d]<0){
            *first=a[0];
            *last=a[k-1];
        }
        return MaxSum;
    }
    int main(){
        int k;
        int *a;
        int num;
        int FirstNum=0,LastNum=0;
        cin>>k;
        a = new int[k];    
        for(int i=0;i<k;i++){        
            cin>>a[i];    
        }
        num=MaxsubseqSum2(a,k,&FirstNum,&LastNum);
            cout<<num<<" "<<FirstNum<<" "<<LastNum;
        delete [] a;
        return 0;
    }

    1

    卡在了测试点3,4,5上面

    测试点3,是考虑数字相同的时候。最开始的姥姥讲的那个算法中,当数字相同的时候,我输出的最小子列和的第一个数会是0。(这也是一种特殊的情况)

    测试点4,是当数字全为负数的时候,first和last为数列的第一个数和最后的一个数字

    测试点5,当0,负数全都在的时候,这是时候first和last应该都为0,而不是像4中一样,first和last为数列的第一个数和最后的一个数字。

  • 相关阅读:
    Flex皮肤制作流程
    AIR app自动更新的实现方式
    Adobe AIR迷你教程 使用自定义窗口以及对窗口的移动,缩放,关闭操作
    AIR数据处理的方法
    Flex中的注释方法
    Flex皮肤设计简单实例教程
    八个常用的AS3开源类库
    as3 如何判断同时按下两个键
    struts2中动态方法调用
    Struts2.3笔记
  • 原文地址:https://www.cnblogs.com/Zengineer/p/4314568.html
Copyright © 2011-2022 走看看