zoukankan      html  css  js  c++  java
  • HDU 1548 A strange lift(简单BFS)

    A strange lift

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 27600    Accepted Submission(s): 9911


    Problem Description
    There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button "UP" , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button "DOWN" , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can't go up high than N,and can't go down lower than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button "UP", and you'll go up to the 4 th floor,and if you press the button "DOWN", the lift can't do it, because it can't go down to the -2 th floor,as you know ,the -2 th floor isn't exist.
    Here comes the problem: when you are on floor A,and you want to go to floor B,how many times at least he has to press the button "UP" or "DOWN"?
     
    Input
    The input consists of several test cases.,Each test case contains two lines.
    The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,....kn.
    A single 0 indicate the end of the input.
     
    Output
    For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can't reach floor B,printf "-1".
     
    Sample Input
    5 1 5 3 3 1 2 5 0
     
    Sample Output
    3
     
     
    每次进行上楼和下楼的两种操作即可
     
    代码如下:
    #include <cstdio>
    #include <iostream>
    #include <queue>
    #include<cstring>
    using namespace std;
    int vis[220];
    int k[220];
    int n,st,en;
    int check(int x)
    {
       if(x>=1&&x<=n&&!vis[x])
       {
           vis[x]=1;
           return 1;
       }
       return 0;
    }
    struct node
    {
        int x;
        int step;
    };
    int bfs()
    {
        memset(vis,0,sizeof(vis));
        node a,next;
        a.x=st;
        a.step=0;
        vis[a.x]=1;
        queue<node>Q;
        Q.push(a);
        while(!Q.empty())
        {
         a=Q.front();
         Q.pop();
         if(a.x==en)return a.step;
         next.step=a.step+1;
          next.x=a.x+k[a.x];
          if(check(next.x))
          Q.push(next);
          next.x=a.x-k[a.x];
          if(check(next.x))
            Q.push(next);
        }
        return -1;
    }
    int main()
    {
       while(scanf("%d",&n)!=EOF)
       {
            if(n==0)break;
            scanf("%d%d",&st,&en);
            for(int i=1;i<=n;i++)
                scanf("%d",&k[i]);
                cout<<bfs()<<endl;
       }
        return 0;
    }
     
  • 相关阅读:
    深入了解Java ClassLoader、Bytecode 、ASM、cglib (I)
    如何在ant里import
    敏捷练习(1)评估我的生活方向盘
    你是一个合格的孩子吗?
    [转] C# 路径(目录)
    XML学习记录
    js学习总结不断更新(1)
    LINQ TO XML练习
    做技术,切不可沉湎于技术
    js学习总结持续更新(2)
  • 原文地址:https://www.cnblogs.com/a249189046/p/7603548.html
Copyright © 2011-2022 走看看