zoukankan      html  css  js  c++  java
  • Programming Ability Test学习 1008. Elevator (20)

    1008. Elevator (20)

    时间限制
    400 ms
    内存限制
    65536 kB
    代码长度限制
    16000 B
    判题程序
    Standard
    作者
    CHEN, Yue

    The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

    For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

    Input Specification:

    Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

    Output Specification:

    For each test case, print the total time on a single line.

    Sample Input:
    3 2 3 1
    
    Sample Output:
    41
    

    提交代码

    注:相加就好

    #include<iostream>
    #include<cstdio>
    #include<cmath>
    #include<cstdlib>
    #include<cstring>
    #include<string>
    #include<algorithm> 
    #include<map>
    #define MAXSIZE 100005
    typedef long long ll;
    
    using namespace std;
    
    
    
    int main()
    {
        
        int A[MAXSIZE];
        int N;
        cin>>N;
        for(int i=0;i<N;i++)cin>>A[i];
        double sum=0;
        sum+=N*5;
        sum+=6*A[0];
        for(int i=1;i<N;i++)
        {
            int k=A[i]-A[i-1];
            if(k>0)sum+=6*k;
            else sum+=(-k)*4;
        }
        
        cout<<sum<<endl;
        return 0;
    } 
    View Code
  • 相关阅读:
    powerdesigner
    UML类图几种关系的总结(转载 http://blog.csdn.net/tianhai110/article/details/6339565 )
    vuex
    options请求(复杂请求)
    Vue 编程式的导航
    JS定义类
    cors中间件
    vue axios
    restframewor 版本(version)
    pycharm 安装vue
  • 原文地址:https://www.cnblogs.com/a842297171/p/4794185.html
Copyright © 2011-2022 走看看