zoukankan      html  css  js  c++  java
  • POJ2533Longest Ordered Subsequence(LIS)

    Description
    A numeric sequence of ai is ordered if a1 < a2 < … < aN. Let the subsequence of the given numeric sequence (a1, a2, …, aN) be any sequence (ai1, ai2, …, aiK), where 1 <= i1 < i2 < … < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

    Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

    Input
    The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

    Output
    Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

    Sample Input

    7
    1 7 3 5 9 4 8

    Sample Output

    4

    #include <iostream>
    #include <algorithm>
    #include <cstring>
    using namespace std;
    int num[1005],dp[1005];
    int main()
    {
        int n;
        while(cin>>n)
        {
        for(int i=0;i<n;i++)
        {
            cin>>num[i];
            dp[i]=1;
        }
        int ans=1;
        for(int i=1;i<n;i++)
        {
            for(int j=0;j<i;j++)
                if(num[i]>num[j])
                dp[i]=max(dp[i],dp[j]+1);
            if(dp[i]>ans)
                ans=dp[i];
        }
        cout<<ans<<endl;
        }
        return 0;
    }

    最简单的lis。。。却卡了我半个小时。。。例题过了却始终提交错误,最终发现将ans初始化为0导致n=1时答案错误。。。谨以此文提醒自己以后不要范类似错误。

  • 相关阅读:
    Grove.net实践ORM学习笔记
    COM+的事务
    Delphi中MIDAS线程模型
    Delphi中封装ADO之我重学习记录。。。
    100 多个JaveScript 常用函数
    javascript 事件
    js 收藏
    js 常用函数
    表单11种Input的高级用法
    UltraEdit 使用技巧
  • 原文地址:https://www.cnblogs.com/acagain/p/9180740.html
Copyright © 2011-2022 走看看