zoukankan      html  css  js  c++  java
  • hdu1083二分图匹配模板题

    onsider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the conditions: 

    . every student in the committee represents a different course (a student can represent a course if he/she visits that course) 

    . each course has a representative in the committee 

    Your program should read sets of data from a text file. The first line of the input file contains the number of the data sets. Each data set is presented in the following format: 

    P N 
    Count1 Student1 1 Student1 2 ... Student1 Count1 
    Count2 Student2 1 Student2 2 ... Student2 Count2 
    ...... 
    CountP StudentP 1 StudentP 2 ... StudentP CountP 

    The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses . from course 1 to course P, each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you'll find the Count i students, visiting the course, each two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N. 

    There are no blank lines between consecutive sets of data. Input data are correct. 

    The result of the program is on the standard output. For each input data set the program prints on a single line "YES" if it is possible to form a committee and "NO" otherwise. There should not be any leading blanks at the start of the line. 

    An example of program input and output:

    Input

    2
    3 3
    3 1 2 3
    2 1 2
    1 1
    3 3
    2 1 3
    2 1 3
    1 1

    Output

    YES
    NO 

    Sample Input

    2
    3 3
    3 1 2 3
    2 1 2
    1 1
    3 3
    2 1 3
    2 1 3
    1 1

    Sample Output

    YES
    NO 
    第一题二分图啊,wa了6遍,后来a了还是不知道当时为啥wa了
    题意:学科与学生匹配,学生必须要有匹配,学科不一定。
    解法:匈牙利算法计数就ok了
    #include<map>
    #include<set>
    #include<list>
    #include<cmath>
    #include<queue>
    #include<stack>
    #include<vector>
    #include<cstdio>
    #include<cstring>
    #include<iostream>
    #include<algorithm>
    #define pi acos(-1)
    #define ll long long
    #define mod 1000000007
    
    using namespace std;
    
    const double eps=1e-8;
    const int N=105,maxn=305,inf=0x3f3f3f3f;
    
    bool ok[maxn][maxn],used[maxn];
    int vis[maxn],n,m,t;
    
    bool match(int x)
    {
        for(int i=1;i<=m;i++)
        {
            if(!used[i]&&ok[x][i])
            {
                used[i]=1;
                if(vis[i]==-1||match(vis[i]))
                {
                    vis[i]=x;
                    return 1;
                }
            }
        }
        return 0;
    }
    int main()
    {
        cin>>t;
        while(t--){
            cin>>n>>m;
            bool flag=0;
            memset(ok,0,sizeof(ok));
            for(int i=1;i<=n;i++)
            {
                int k,a;
                cin>>k;
                if(k==0)flag=1;
                while(k--){
                    cin>>a;
                    ok[i][a]=1;
                }
            }
            memset(vis,-1,sizeof(vis));
            int i,num=0;
            for(i=1;i<=n;i++)
            {
                memset(used,0,sizeof(used));
                if(!match(i))break;
            }
            if(i==n+1)cout<<"YES"<<endl;
            else cout<<"NO"<<endl;
        }
        return 0;
    }
  • 相关阅读:
    Eclipse无法正常启动,弹出对话框内容为 A Java Runtime...
    redis入门常用的命令操作(总结 一)
    初级工程师的面试
    公司金融学理论--MM理论
    以太坊开发环境搭建
    如何以树形结构显示文件目录结构
    Neural Network Basics
    大前端公共知识梳理
    出SS表
    iOS weak关键字
  • 原文地址:https://www.cnblogs.com/acjiumeng/p/6730714.html
Copyright © 2011-2022 走看看