zoukankan      html  css  js  c++  java
  • hdu 1050 Moving Tables

    Moving Tables

    http://acm.hdu.edu.cn/showproblem.php?pid=1050

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 14896    Accepted Submission(s): 5096


    Problem Description
    The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure.



    The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving.



    For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.
     
    Input
    The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case begins with a line containing an integer N , 1<=N<=200 , that represents the number of tables to move. Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t (each room number appears at most once in the N lines). From the N+3-rd line, the remaining test cases are listed in the same manner as above.
     
    Output
    The output should contain the minimum time in minutes to complete the moving, one per line.
     
    Sample Input
    3
    4
    10 20
    30 40
    50 60
    70 80
    2
    1 3
    2 200
    3
    10 100
    20 80
    30 50
    Sample Output
    10
    20
    30
    看了别人的代码,知道原来只要计算出区间重叠的最大次数,再乘以十就可以了。。。思维还木有打开啊
    题目注意:
    1.  输入的两个数  a,b  a可以大于b
    2.  1 2 对应同一段区间
    #include<iostream>
    #include<string.h>
    using namespace std;
    int main()
    {
        int i,j,t,n,q[201];
        cin>>t;
        while(t--)
        {
            memset(q,0,sizeof(q));
            cin>>n;
            for(i=0;i<n;i++)
            {
                int a,b,t;
                cin>>a>>b;
                if(a>b)
                {
                    t=a;a=b;b=t;
                }
                if(a%2)
                    a++;
                if(b%2)
                    b++;
                for(j=a/2;j<=b/2;j++)
                    q[j]++;
            }
            int max=0;
            for(i=1;i<=200;i++)
            if(q[i]>max)
                max=q[i];
            cout<<max*10<<endl;
        }
    }
    View Code
  • 相关阅读:
    写一个Windows上的守护进程(4)日志其余
    写一个Windows上的守护进程(3)句柄的管理
    写一个Windows上的守护进程(2)单例
    写一个Windows上的守护进程(1)开篇
    Xcode 特定项目运行提示无响应
    git squash 的使用
    关于.framework 文件过大 移除包内对i386 x86_64 的支持
    git 恢复被覆盖本地提交内容
    iOS企业应用 部署配置
    关于项目中测试环境跟正式环境的区分
  • 原文地址:https://www.cnblogs.com/ainixu1314/p/3219188.html
Copyright © 2011-2022 走看看