zoukankan      html  css  js  c++  java
  • 1037. Magic Coupon (25)

    题目如下:

    The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product... but hey, magically, they have some coupons with negative N's!

    For example, given a set of coupons {1 2 4 -1}, and a set of product values {7 6 -2 -3} (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

    Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains the number of coupons NC, followed by a line with NC coupon integers. Then the next line contains the number of products NP, followed by a line with NP product values. Here 1<= NC, NP <= 105, and it is guaranteed that all the numbers will not exceed 230.

    Output Specification:

    For each test case, simply print in a line the maximum amount of money you can get back.

    Sample Input:
    4
    1 2 4 -1
    4
    7 6 -2 -3
    
    Sample Output:
    43
    

    题目很简单,为了得到钱,我们只能通过两种途径,①正优惠券对应正的商品,②负优惠券对应负的商品。

    对于正数,我们按照降序排序以获得最大的优惠券和最高价的商品。

    对于负数,我们按照升序排序以获得绝对值最大的优惠券和商品。

    因此,我们需要把正、负分开统计,因此需要4个容器(coupon和product各+、-两个)。

    排序结束后,从前到后累加优惠券数值和商品数值的乘积,注意遍历容器时设置结束条件为较小的容器的大小。

    #include <iostream>
    #include <vector>
    #include <stdio.h>
    #include <algorithm>
    
    using namespace std;
    
    int comparePos(int a, int b){
        return a > b;
    }
    
    int compareNeg(int a, int b){
        return a < b;
    }
    
    int main()
    {
        vector<int> posCoupons,negCoupons;
        vector<int> posProducts,negProducts;
        int N;
        cin >> N;
        int buffer;
        for(int i = 0; i < N; i++){
            scanf("%d",&buffer);
            if(buffer >= 0){
                posCoupons.push_back(buffer);
            }else{
                negCoupons.push_back(buffer);
            }
        }
        cin >> N;
            for(int i = 0; i < N; i++){
            scanf("%d",&buffer);
            if(buffer >= 0){
                posProducts.push_back(buffer);
            }else{
                negProducts.push_back(buffer);
            }
        }
        sort(posCoupons.begin(),posCoupons.end(),comparePos);
        sort(negCoupons.begin(),negCoupons.end(),compareNeg);
        sort(posProducts.begin(),posProducts.end(),comparePos);
        sort(negProducts.begin(),negProducts.end(),compareNeg);
    
        // 首先组合正的coupons和正的products
        int thres = posCoupons.size() > posProducts.size() ? posProducts.size() : posCoupons.size();
        int sum = 0;
        for(int i = 0; i < thres; i++){
            sum += posCoupons[i] * posProducts[i];
        }
        // 然后组合负的coupons和负的products
        thres = negCoupons.size() > negProducts.size() ? negProducts.size() : negCoupons.size();
        for(int i = 0; i < thres; i++){
            sum += negCoupons[i] * negProducts[i];
        }
        cout << sum << endl;
        return 0;
    }
    


  • 相关阅读:
    linux kill命令以及 信号
    rhel7 系统服务——unit(单元)
    redis集群在线迁移
    二、主目录 Makefile 分析(3)
    二、主目录 Makefile 分析(2)
    二、主目录 Makefile 分析(1)
    一、文档目录分析
    Linux下解压缩
    设备树
    轮询
  • 原文地址:https://www.cnblogs.com/aiwz/p/6154157.html
Copyright © 2011-2022 走看看