zoukankan      html  css  js  c++  java
  • POJ 1207 The 3n + 1 problem

    POJ 1207 The 3n + 1 problem
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 63484   Accepted: 20031

    Description

    Problems in Computer Science are often classified as belonging to a certain class of problems (e.g., NP, Unsolvable, Recursive). In this problem you will be analyzing a property of an algorithm whose classification is not known for all possible inputs. 
    Consider the following algorithm: 


    1. input n

    2. print n

    3. if n = 1 then STOP

    4. if n is odd then n <-- 3n+1

    5. else n <-- n/2

    6. GOTO 2

    Given the input 22, the following sequence of numbers will be printed 22 11 34 17 52 26 13 40 20 10 5 16 8 4 2 1 

    It is conjectured that the algorithm above will terminate (when a 1 is printed) for any integral input value. Despite the simplicity of the algorithm, it is unknown whether this conjecture is true. It has been verified, however, for all integers n such that 0 < n < 1,000,000 (and, in fact, for many more numbers than this.) 

    Given an input n, it is possible to determine the number of numbers printed before the 1 is printed. For a given n this is called the cycle-length of n. In the example above, the cycle length of 22 is 16. 

    For any two numbers i and j you are to determine the maximum cycle length over all numbers between i and j. 


    Input

    The input will consist of a series of pairs of integers i and j, one pair of integers per line. All integers will be less than 10,000 and greater than 0. 

    You should process all pairs of integers and for each pair determine the maximum cycle length over all integers between and including i and j. 

    Output

    For each pair of input integers i and j you should output i, j, and the maximum cycle length for integers between and including i and j. These three numbers should be separated by at least one space with all three numbers on one line and with one line of output for each line of input. The integers i and j must appear in the output in the same order in which they appeared in the input and should be followed by the maximum cycle length (on the same line).

    Sample Input

    1 10
    100 200
    201 210
    900 1000

    Sample Output

    1 10 20
    100 200 125
    201 210 89
    900 1000 174

    Source

     
    #include<iostream>
    using namespace std;
     
    int CycleNum(int i)
    {
        int count=1;
        while(i!=1)
        {
            if(i%2)
                i=3*i+1;
            else
                i/=2;
            count++;
        }
        return count;
    }
     
    int main(void)
    {
        int a,b;
        while(cin>>a>>b)
        {
            int x=a<b?a:b;
            int y=a>b?a:b;
            int MaxCycle=0;
            for(int i=x;i<=y;i++)
            {
                int temp=CycleNum(i);
                if(MaxCycle<temp)
                    MaxCycle=temp;
            }
            cout<<a<<' '<<b<<' '<<MaxCycle<<endl;
        }
        return 0;
    } 
  • 相关阅读:
    JSP Web第五章整理复习 JSP访问数据库
    JSP Web第四章整理复习 JSP技术基础
    JSP Web第三章整理复习 开发环境搭建
    在n个球中,任意取出m个(不放回),求共有多少种取法
    递归比较字符串是否相等
    数组求和的3种常见递归方法
    打印begin~end
    jQuery简单实现图片预加载
    HTML5语义化标签重构页面
    jQuery插件slick实现响应式移动端幻灯片图片切换特效—大全
  • 原文地址:https://www.cnblogs.com/alan-blog-TsingHua/p/10640075.html
Copyright © 2011-2022 走看看