zoukankan      html  css  js  c++  java
  • POJ3169--Layout(SPFA+差分系统)

    Description

    Like everyone else, cows like to stand close to their friends when queuing for feed. FJ has N (2 <= N <= 1,000) cows numbered 1..N standing along a straight line waiting for feed. The cows are standing in the same order as they are numbered, and since they can be rather pushy, it is possible that two or more cows can line up at exactly the same location (that is, if we think of each cow as being located at some coordinate on a number line, then it is possible for two or more cows to share the same coordinate). 

    Some cows like each other and want to be within a certain distance of each other in line. Some really dislike each other and want to be separated by at least a certain distance. A list of ML (1 <= ML <= 10,000) constraints describes which cows like each other and the maximum distance by which they may be separated; a subsequent list of MD constraints (1 <= MD <= 10,000) tells which cows dislike each other and the minimum distance by which they must be separated. 

    Your job is to compute, if possible, the maximum possible distance between cow 1 and cow N that satisfies the distance constraints.

    Input

    Line 1: Three space-separated integers: N, ML, and MD. 

    Lines 2..ML+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at most D (1 <= D <= 1,000,000) apart. 

    Lines ML+2..ML+MD+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at least D (1 <= D <= 1,000,000) apart.

    Output

    Line 1: A single integer. If no line-up is possible, output -1. If cows 1 and N can be arbitrarily far apart, output -2. Otherwise output the greatest possible distance between cows 1 and N.

    Sample Input

    4 2 1
    1 3 10
    2 4 20
    2 3 3

    Sample Output

    27

    Hint

    Explanation of the sample: 

    There are 4 cows. Cows #1 and #3 must be no more than 10 units apart, cows #2 and #4 must be no more than 20 units apart, and cows #2 and #3 dislike each other and must be no fewer than 3 units apart. 

    The best layout, in terms of coordinates on a number line, is to put cow #1 at 0, cow #2 at 7, cow #3 at 10, and cow #4 at 27.
     
    ---------
     
    对于差分系统的讲解在这个讲的比较清楚
    https://blog.csdn.net/mengxiang000000/article/details/52613328
     
    如果仅仅用Bellman-Ford会TLE
    所以需要优化,使用SPFA
    http://www.cnblogs.com/shadowland/p/5870640.html
    这个对spfa讲解的比较清楚
     
     
    AC代码:
    #include<iostream>
    #include<algorithm> 
    #include<queue>
    #include<vector>
    using namespace std;
    
    struct edge{
        int from,to,cost;
    };
    int visit[1005];
    int cnt[1005];
    int d[1005];
    queue<int> que;
    int n,size,sum;
    vector<edge> es;
    
    int main(){
        int ml,md;
        cin>>n>>ml>>md;
        sum=ml+md;
        es.resize(sum);
        for(int i=0;i<ml;i++){
            int a,b,c;
            cin>>a>>b>>c;
            edge e={a,b,c};
            es[i]=e;
        }
        for(int i=ml;i<ml+md;i++){
            int a,b,c;
            cin>>a>>b>>c;
            edge e={b,a,-c};
            es[i]=e;
        }
        for(int i=1;i<n;i++){
            edge e={i+1,i,0};
            es.push_back(e);
        }
        size=es.size();
        
        for(int i=1;i<=n;i++)
            d[i]=INT_MAX;    
        d[1]=0;
        que.push(1);
        visit[1]=1;
        cnt[1]++;
        while(!que.empty()){
            int p=que.front();
            que.pop();
            visit[p]=0;
            for(int i=0;i<size;i++){
                edge e=es[i];
                if(e.from==p&&d[e.from]+e.cost<d[e.to]){
                    d[e.to]=d[e.from]+e.cost;
                    if(visit[e.to]==0){
                        cnt[e.to]++;
                        if(cnt[e.to]>=n){
                            cout<<-1;
                            return 0;
                        }
                        que.push(e.to);
                        visit[e.to]=1;
                    }
                }
            }
        }
        if(d[n]==INT_MAX)
            cout<<-2;
        else 
            cout<<d[n];
        return 0;
    } 
  • 相关阅读:
    centos7.6 安装与配置 MongoDB yum方式
    MongoDB 介绍
    centos 关闭selinux
    前端 HTML标签属性
    前端 HTML 标签嵌套规则
    前端 HTML 标签分类
    前端 HTML body标签相关内容 常用标签 表单标签 form里面的 input标签介绍
    前端 HTML body标签相关内容 常用标签 表单标签 form 表单控件分类
    前端 HTML form表单标签 select标签 option 下拉框
    POJ 1426
  • 原文地址:https://www.cnblogs.com/albert67/p/10329717.html
Copyright © 2011-2022 走看看