zoukankan      html  css  js  c++  java
  • POJ3273--Monthly Expense(Binary Search)

    Description

    Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.

    FJ wants to create a budget for a sequential set of exactly M (1 ≤ M ≤ N) fiscal periods called "fajomonths". Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

    FJ's goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

    Input

    Line 1: Two space-separated integers: N and M 
    Lines 2..N+1: Line i+1 contains the number of dollars Farmer John spends on the ith day

    Output

    Line 1: The smallest possible monthly limit Farmer John can afford to live with.

    Sample Input

    7 5
    100
    400
    300
    100
    500
    101
    400

    Sample Output

    500

    Hint

    If Farmer John schedules the months so that the first two days are a month, the third and fourth are a month, and the last three are their own months, he spends at most $500 in any month. Any other method of scheduling gives a larger minimum monthly limit.
     
    #include<iostream>
    #include<numeric>
    #include<algorithm>
    using namespace std;
    int money[100005];
    int n,m;
    
    bool C(int d){
        int periods=1,curSum=0;
        for(int i=0;i<n;i++){
            curSum+=money[i];
            if(curSum>d){
                curSum=money[i];
                periods++;
            }
            if(periods>m)
                return false;
        }
        return true;
    }
    
    int main(){
        while(cin>>n>>m){
                    for(int i=0;i<n;i++){
            cin>>money[i];
        }
        int lb=*max_element(money,money+n);
        int ub=accumulate(money,money+n,0);
        int mid=(lb+ub)/2;
        while(ub>lb){
            if(C(mid))
                ub=mid-1;
            else
                 lb=mid+1;
            mid=(lb+ub)/2;
        }
        cout<<mid<<endl;
        
        }
    return 0;
    }
  • 相关阅读:
    MySQL监控、性能分析——工具篇
    [转载]Error -27796: Failed to connect to server
    Tomcat最大连接数问题
    Jconsole的使用
    通过jconsole监控tomcat JVM 内存、线程、CPU
    Tomcat部署web项目
    tomcat部署web项目的3中方法
    在linux下修改oracle的sys和system的密码和用户解锁
    静默安装oracle11G
    Linux 卸载Oracle 11G
  • 原文地址:https://www.cnblogs.com/albert67/p/10391142.html
Copyright © 2011-2022 走看看